uva 408 Uniform Generator

Uniform Generator 

Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

 

displaymath29

 

where `` tex2html_wrap_inline31 " is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

 

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

 

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

 

Input

Each line of input will contain a pair of integers for STEP and MOD in that order ( tex2html_wrap_inline77 ).

 

Output

For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either ``Good Choice" or ``Bad Choice" left-justified starting in column 25. The ``Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message ``Bad Choice". After each output test set, your program should print exactly one blank line.

 

Sample Input

 

3 5
15 20
63923 99999

 

Sample Output

 

         3         5    Good Choice

        15        20    Bad Choice

     63923     99999    Good Choice

题目大意:给出n , mod ,step = (n + step) % mod ,问,step是否能取到0~mod - 1之间所有的数。

解题思路:题目可以等价于判断n 和 mod 的最大公约数是否为1.

理由为想了好久,现在给大家证明一下:

首先,题目可以近似与(k * n ) % mod , k 为0 ~ g-1( g 为非0数且g * n% mod =0),因为k要是大于g,那余数就形成循环。

1:当n 与 mod 的最大公约数为1 时,它们之间的最小公约数即为n* mod, 也就是说g = mod,也就是说g个k值分别对应不同的mod(0 ` mod - 1)个step(中间不能形成循环,否则矛盾,所以k 与step一一对应)。

2:当n 与 mod 的最大公约数不为1时, 设 k 为两数的最大公约数, n = a * k, mod = b * k, n % mod 的余数集合A=a % b 的余数集合 B* k.

由1的结论可以知道 B集合即为0~b -1,举个反例: 1 * k , 2 * k , 若是k = 2,取得到2  、4,而 1、3 就不包含在A集合中了。

#include<stdio.h>
int judge(int n, int m){
	for (int i = 2; i <= n && i <= m; i++){
		if (n % i == 0 && m % i == 0)
			return 0;
	}
	return 1;}
int main(){
	int n, m;
	while (scanf("%d%d", &n, &m) !=EOF){
		printf("%10d%10d", n, m);
		if (judge(n, m))
			printf("    Good Choice

");
		else
			printf("    Bad Choice

");
	}
	return 0;}


原文地址:https://www.cnblogs.com/jiangu66/p/3221628.html