uva 10004

 

  Bicoloring 

In 1976 the ``Four Color Map Theorem" was proven with the assistance of a computer. This theorem states that every map can be colored using only four colors, in such a way that no region is colored using the same color as a neighbor region.

Here you are asked to solve a simpler similar problem. You have to decide whether a given arbitrary connected graph can be bicolored. That is, if one can assign colors (from a palette of two) to the nodes in such a way that no two adjacent nodes have the same color. To simplify the problem you can assume:

  • no node will have an edge to itself.
  • the graph is nondirected. That is, if a node a is said to be connected to a node b, then you must assume that b is connected to a.
  • the graph will be strongly connected. That is, there will be at least one path from any node to any other node.

Input 

The input consists of several test cases. Each test case starts with a line containing the number n ( 1 < n < 200) of different nodes. The second line contains the number of edges l. After this, l lines will follow, each containing two numbers that specify an edge between the two nodes that they represent. A node in the graph will be labeled using a number a ( $0 le a < n$).

An input with n = 0 will mark the end of the input and is not to be processed.

Output 

You have to decide whether the input graph can be bicolored or not, and print it as shown below.

Sample Input 

3
3
0 1
1 2
2 0
9
8
0 1
0 2
0 3
0 4
0 5
0 6
0 7
0 8
0

Sample Output 

NOT BICOLORABLE.
BICOLORABLE.
#include <iostream>
#include <stack>
#include <cstring>
#include <cstdio>
#include <string>
#include <algorithm>
#include <queue>
#include <set>
#include <map>
#include <fstream>
#include <stack>
#include <list>
#include <sstream>
#include <cmath>

using namespace std;

#define ms(arr, val) memset(arr, val, sizeof(arr))
#define mc(dest, src) memcpy(dest, src, sizeof(src))
#define N 205
#define INF 0x3fffffff
#define vint vector<int>
#define setint set<int>
#define mint map<int, int>
#define lint list<int>
#define sch stack<char>
#define qch queue<char>
#define sint stack<int>
#define qint queue<int>

int cnt, ans, front[N];
int tag[N];
struct node
{
    int next, to;
}edge[40005];

void addedge(int s, int e)
{
    edge[cnt].next = front[s];
    front[s] = cnt;
    edge[cnt++].to = e;
}

void dfs(int i)
{
    for (int s = front[i]; s != -1; s = edge[s].next)
    {
        if (tag[edge[s].to])
        {
            if (tag[edge[s].to] == tag[i])
            {
                ans = 0;
                return;
            }
        }
        else
        {
            tag[edge[s].to] = -tag[i];
            dfs(edge[s].to);
        }
    }
}

int main()
{
    //freopen("1.cpp", "r", stdin);
    int n, l, s, e;
    while (scanf("%d", &n), n)
    {
        scanf("%d", &l);
        ms(front, -1);
        ms(tag, 0);
        ans = tag[0] = 1;
        cnt = 0;
        while (l--)
        {
            scanf("%d%d", &s, &e);
            addedge(s, e);
            addedge(e, s);
        }
        dfs(0);
        puts((ans ? "BICOLORABLE." : "NOT BICOLORABLE."));
    }

    return 0;
}
原文地址:https://www.cnblogs.com/jecyhw/p/3914697.html