hdu 1856 More is better

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 14530    Accepted Submission(s): 5334


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 
Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 
Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 
Sample Input
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 
Sample Output
4 2
#include <iostream>
#include <stack>
#include <cstring>
#include <cstdio>
#include <string>
#include <algorithm>
#include <queue>
#include <set>
#include <map>

using namespace std;
/*
并查集,并记录每个集合的个数,取最大;
但是a, b范围很大,采用map;
为了方便,记录集合个数也用map;
map超时,百度了下,居然可以开10000005这么大的数组
*/
#define ms(arr, val) memset(arr, val, sizeof(arr))
#define N 10000005
#define INF 0x3fffffff
#define vint vector<int>
#define sint set<int>
#define mint map<int, int>

int mp[N], con[N];
int ans;
int find(int x)//查找
{
    int fx = x;
    while (mp[fx])
    {
        fx = mp[fx];
    }
    int t = x;
    while (t != fx)/*路径压缩*/
    {
        x = mp[t];
        mp[t] = fx;
        t = x;
    }
    return fx;
}

bool _union(int fx, int fy)//合并
{
    if (fx == fy)
    {
        return false;
    }
    mp[fy] = fx;/*将fy并到fx上*/
    con[fx] += con[fy];
    if (con[fx] > ans)
    {
        ans = con[fx];
    }
    return true;
}

int main()
{
    int n, a, b;
    while (cin >> n)
    {
        ms(mp, 0);
        ms(con, 0);
        ans = 0;
        while (n--)
        {
            cin >> a >> b;
            if (!con[a])
            {
                con[a] = 1;
            }
            if (!con[b])
            {
                con[b] = 1;
            }
            _union(find(a), find(b));
        }
        if (!ans)//没有则为1
        {
            ans = 1;
        }
        cout << ans << endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/jecyhw/p/3897566.html