HDU_1506_Largest Rectangle in a Histogram_dp

Largest Rectangle in a Histogram

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14177    Accepted Submission(s): 4049


Problem Description
A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
 
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
 
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
 
Sample Input
7 2 1 4 5 1 3 3 4 1000 1000 1000 1000 0
 
Sample Output
8 4000
 
2016.4.22再次做,一开始毫无思路,又看了题解。。。
思想:找出每一个单位宽度矩形的左边界(dpl)和右边界(dpr),左边界定义为左边连续的高度大于等于它的最左边的矩形的下标,右边界同理,从左往右推出所有的左边界,从右往左推出所有的右边界。
注意矩形的高度h可以等于零,以为这当左边边上的矩形高为零或者右边边界上矩形高度为零时,while循环无法停止,所以在while循环的条件中要加上限制边界的条件。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 100005

long long dpl[N],dpr[N],hei[N],maxn,t;
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF&&n)
    {
        maxn=0;
        for(int i=1;i<=n;i++)
            scanf("%I64d",&hei[i]);
        dpl[1]=1;
        dpr[n]=n;
        for(int i=2;i<=n;i++)   //找当前矩形左边能延伸到的矩形,第几个,下标
        {
            t=i;
            while(t>1&&hei[i]<=hei[t-1])
                t=dpl[t-1];
            dpl[i]=t;
        }
        for(int i=n-1;i;i--)   //找当前矩形右边能够延伸到的矩形,第几个,下标
        {
            t=i;
            while(t<n&&hei[i]<=hei[t+1])
                t=dpr[t+1];
            dpr[i]=t;
        }
        for(int i=1;i<=n;i++)
        {
            long long tot=(dpr[i]-dpl[i]+1)*hei[i];
            if(tot>maxn)
                maxn=tot;
        }
        cout<<maxn<<endl;
    }
    return 0;
}

  

原文地址:https://www.cnblogs.com/jasonlixuetao/p/4707606.html