HDU 1757 A Simple Math Problem (矩阵乘法)

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1697    Accepted Submission(s): 959


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 
Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 
Output
For each case, output f(k) % m in one line.
 
Sample Input
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 
Sample Output
45 104
 
Author
linle
 
Source
 
Recommend
lcy
 

 
If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);

|f(10) |       |a0 a1 a2 ...a8 a9|    |f(9)|
| f(9)  |       | 1   0   0 ... 0    0 |    |f(8)|
| .....  |   =  | ..    ...    ...   ...    |    | .. |
| f(2) |        | 0   0   0 ... 0    0|     |f(1)|
| f(1) |   | 0   0   0 ... 1    0|     |f(0)|

另A举证为10*10的举证,如上图。
可以推出:
(f(n),f(n-1),...,f(n-9))^(-1) = A^(n-9)*(f(9),f(8),...,f(0))^(-1)

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

long long k,mod;

struct Matrix{
    int m[15][15];
};

Matrix unit,init;

void Init(){
    memset(init.m,0,sizeof(init.m));
    for(int i=1;i<10;i++)
        init.m[i][i-1]=1;
    memset(unit.m,0,sizeof(unit.m));
    for(int i=0;i<10;i++)
        unit.m[i][i]=1;
}

Matrix Mul(Matrix a,Matrix b){
    Matrix c;
    for(int i=0;i<10;i++)
        for(int j=0;j<10;j++){
            c.m[i][j]=0;
            for(int k=0;k<10;k++)
                c.m[i][j]+=(a.m[i][k]*b.m[k][j])%mod;
            c.m[i][j]%=mod;
        }
    return c;
}

Matrix Pow(Matrix a,Matrix b,int x){
    while(x){
        if(x&1){
            b=Mul(a,b);
        }
        a=Mul(a,a);
        x>>=1;
    }
    return b;
}

int main(){

    //freopen("input.txt","r",stdin);

    while(cin>>k>>mod){
        Init();
        for(int i=0;i<10;i++)
            scanf("%d",&init.m[0][i]);
        if(k<10){
            cout<<k%mod<<endl;
            continue;
        }
        Matrix res=Pow(init,unit,k-9);
        int ans=0;
        for(int i=0;i<10;i++)
            ans+=(res.m[0][i]*(9-i))%mod;
        cout<<ans%mod<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/jackge/p/3145939.html