POJ 2506 Tiling

Tiling
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6746   Accepted: 3291

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

Source

import java.util.*;
import java.math.*;

public class Main{
    public static void main(String[] args){
        Scanner cin=new Scanner(System.in);
        int n;
        while(cin.hasNext()){
            n=cin.nextInt();
            if(n==0){
                System.out.println("1");
                continue;
            }else if(n==1){
                System.out.println("1");
                continue;
            }else if(n==2){
                System.out.println("3");
                continue;
            }
                
            BigInteger a=BigInteger.valueOf(1);
            BigInteger b=BigInteger.valueOf(3);
            BigInteger c;
            for(int i=3;i<=n;i++){
                c=b.add(a.multiply(BigInteger.valueOf(2)));
                a=b;
                b=c;
            }
            System.out.println(b);
        }
    }
}
原文地址:https://www.cnblogs.com/jackge/p/3140676.html