HDU 1054 Strategic Game

Strategic Game

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3580    Accepted Submission(s): 1573


Problem Description
Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree: 

 

the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:
 
Sample Input
4 0:(1) 1 1:(2) 2 3 2:(0) 3:(0) 5 3:(3) 1 4 2 1:(1) 0 2:(0) 0:(0) 4:(0)
 
Sample Output
1 2
 
Source
 
Recommend
JGShining

 1,二部图:建图要注意,否则会超时

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>

using namespace std;

const int N=1510;

vector<int> mp[N];
int n,linker[N],vis[N];

int DFS(int u){
    int v;
    for(v=0;v<(int)mp[u].size();v++)
        if(!vis[mp[u][v]]){
            vis[mp[u][v]]=1;
            if(linker[mp[u][v]]==-1 || DFS(linker[mp[u][v]])){
                linker[mp[u][v]]=u;
                return 1;
            }
        }
    return 0;
}

int Hungary(){
    int u,ans=0;
    memset(linker,-1,sizeof(linker));
    for(u=0;u<n;u++){
        memset(vis,0,sizeof(vis));
        if(DFS(u))
            ans++;
    }
    return ans;
}

int main(){

    //freopen("input.txt","r",stdin);

    while(~scanf("%d",&n)){
        int u,v,k;
        for(int i=0;i<n;i++)
            mp[i].clear();
        for(int i=0;i<n;i++){
            scanf("%d:(%d)",&u,&k);
            while(k--){
                scanf("%d",&v);
                mp[u].push_back(v);
                mp[v].push_back(u);
            }
        }
        printf("%d\n",Hungary()/2);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/jackge/p/3090442.html