POJ 1364 King (差分约束)

King
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 8534   Accepted: 3221

Description

Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: ``If my child was a son and if only he was a sound king.'' After nine months her child was born, and indeed, she gave birth to a nice son. 
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence. 

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son's skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions. 

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong. 

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, ..., aSi+ni} of a sequence S = {a1, a2, ..., an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + ... + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + ... + aSi+ni < ki or aSi + aSi+1 + ... + aSi+ni > ki resp.) and declared these constraints as his decisions. 

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not. 

Input

The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king's decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0

Sample Output

lamentable kingdom
successful conspiracy

Source

 
 
 

题意:对于一个序列数字序列S。给出(si, ni, 0, ki)。

      如果是(si,ni,gt,ki),意思就是存在约束条件S[si]+S[si+1]+...S[si+ni] > ki,

      如果是(si,ni,lt,ki),意思就是存在约束条件S[si]+S[si+1]+...S[si+ni] < ki  
      判断所给的约束条件有无解,即是否存在这么一个序列S,有解就输出lamentable kingdom,无解就输出successful conspiracy。

思路:将这些约束条件转化为差分约束,不妨设T[x] = S[1]+S[2]+....S[x],那么上面式子就可以转化为: 

     1. T[si+ni] - T[si-1] > ki          2. T[si+ni] - T[si-1] < ki  

     又差分约束系统的求解只能针对>=或<=,无法求解>的系统,还好ki是整数,可以很容易将<转化为<=  
     1. T[si-1] - T[si+ni] <= -ki - 1    2. T[si+ni] - T[si-1] <= ki - 1  

     ///////这想法是 一位叫依然的人的,直接copy过来了

差分约束问题 如果没给出源点,就得自己设一个超级源点,把所有的点连起来 这道题还有一个注意的是,点的个数,不是n个,而是N+2个!!!

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int VM=150;
const int EM=300;
const int INF=0x3f3f3f3f;

int n,m,head[VM],cnt;

struct Edge{
    int v,w,nxt;
}edge[EM];

void addedge(int cu,int cv,int cw){
    edge[cnt].v=cv;
    edge[cnt].w=cw;
    edge[cnt].nxt=head[cu];
    head[cu]=cnt++;
}

int vis[VM],dis[VM],count[VM],q[VM];

int SPFA(){
    for(int i=0;i<=n;i++){  //原来从1开始初始化wa了N遍
        vis[i]=0;
        count[i]=0;
        dis[i]=INF;
    }
    dis[n+2]=0;
    int front=0,rear=0;
    q[rear++]=n+2;
    vis[n+2]=1;
    count[n+2]=1;
    while(front!=rear){
        int u=q[front++];
        front=front%(n+5);
        vis[u]=0;
        for(int i=head[u];i!=-1;i=edge[i].nxt){
            int v=edge[i].v;
            if(dis[v]>dis[u]+edge[i].w){
                dis[v]=dis[u]+edge[i].w;
                if(!vis[v]){
                    vis[v]=1;
                    count[v]++;
                    if(count[v]>n+1)    //原来有N+1个点,外加一个超级源点 所以是入队列次数>=n+2才有负环
                        return 0;
                    q[rear++]=v;
                    rear=rear%(n+5);
                }
            }
        }
    }
    return 1;
}

int main(){

    //freopen("input.txt","r",stdin);

    char ch[4];
    while(~scanf("%d",&n) && n){
        scanf("%d",&m);
        memset(head,-1,sizeof(head));
        cnt=0;
        int si,ni,ki;
        while(m--){
            scanf("%d%d%s%d",&si,&ni,ch,&ki);
            if(ch[0]=='g')
                addedge(si+ni,si-1,-ki-1);  //0<v1<= 100 所点点包含有0 其有n+1个点
            else    
                addedge(si-1,si+ni,ki-1);
        }
        for(int i=1;i<=n;i++)
            addedge(n+2,i,0);
        int ans=SPFA();
        if(ans==0)
            printf("successful conspiracy\n");
        else
            printf("lamentable kingdom\n");
    }
    return 0;
}
原文地址:https://www.cnblogs.com/jackge/p/3061886.html