POJ 2954 Treasure Exploration (floyd传递闭包)

Treasure Exploration
Time Limit: 6000MS   Memory Limit: 65536K
Total Submissions: 5875   Accepted: 2343

Description

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you. 
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure. 
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point. 
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars. 
As an ICPCer, who has excellent programming skill, can your help EUC?

Input

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.

Output

For each test of the input, print a line containing the least robots needed.

Sample Input

1 0
2 1
1 2
2 0
0 0

Sample Output

1
1
2

Source

 
 
题意:地球人要到火星去寻宝,派机器人去战,每个机器人能走多条路,在每个点进行寻宝 为了使花费最小,所以要尽可能少的派机器人。

  1. //传递闭包的建立(Floyd) + 最小路径覆盖  
  2. //这题有别于1422,原因在于它是一个有向图,而非DAG,机器人可以绕一圈回来在走其他路  
  3. //the roads of two different robots may contain some same point.  
  4. //例如1->2,2->3,3->4,4->2,2->5这一个有向图,这个图只要1个机器人就可以走完所有路,但如果不建立传递闭包  
  5. //直接根据边进行匹配,那样得出来的结果是不正确的,因为平时所指的路径覆盖,顶点最多只经过一次,而这道题是可以经过多次的  
  6. //因此必须用floyd重新确定连通性,建立一个传递闭包,根据这个闭包建立新的图,使得满足每个顶点只经过一次  
  7. //这样再用二分图最大匹配的方法求最小路径覆盖就可以了
 
 
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int N=520;

int n,m;
int map[N][N],linker[N],vis[N];

int DFS(int u){
    int v;
    for(v=1;v<=n;v++)
        if(map[u][v] && !vis[v]){
            vis[v]=1;
            if(linker[v]==-1 || DFS(linker[v])){
                linker[v]=u;
                return 1;
            }
        }
    return 0;
}

int Hungary(){
    int u,ans=0;
    memset(linker,-1,sizeof(linker));
    for(u=1;u<=n;u++){
        memset(vis,0,sizeof(vis));
        if(DFS(u))
            ans++;
    }
    return ans;
}

int main(){

    //freopen("input.txt","r",stdin);

    while(~scanf("%d%d",&n,&m)){
        if(n==0 && m==0)
            break;
        memset(map,0,sizeof(map));
        int u,v;
        for(int i=1;i<=m;i++){
            scanf("%d%d",&u,&v);
            map[u][v]=1;
        }
        for(int k=1;k<=n;k++)
            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                    if(map[i][k] && map[k][j])
                        map[i][j]=1;
        int ans=Hungary();
        printf("%d\n",n-ans);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/jackge/p/3056447.html