POJ 1860 Currency Exchange (Bellman)

Currency Exchange
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 15324   Accepted: 5275

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

Source

Northeastern Europe 2001, Northern Subregion
 
 
题意: 每种货币间有一定的交换比率,而且要付一定的佣金,问nick 经过多次交换后,能否赚钱

思路:原来以为 经过NE次松驰后,只要dis[src] > w 他就能赚钱 但想想这是错了。而应该是判断有没有存在正环 因为 可能NE次松驰后,dis[src] 没有大于w 但它存在正环,只要再继续松驰,就一定有dis[src] > w;
 
 
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int VM=120;
const int EM=120;
const int INF=0x3f3f3f3f;

struct Edge{
    int u,v;
    double r,c;
}edge[EM<<1];

int n,m,s,cnt;
double V,dis[VM];

void addedge(int cu,int cv,double cr,double cc){
    edge[cnt].u=cu;     edge[cnt].v=cv;     edge[cnt].r=cr;
    edge[cnt].c=cc;     cnt++;
}

int Bellman_ford(){
    int i,j;
    for(i=1;i<=n;i++)
        dis[i]=0;
    dis[s]=V;
    for(i=1;i<=n;i++){
        int flag=0;
        for(j=0;j<cnt;j++)
            if(dis[edge[j].v]<(dis[edge[j].u]-edge[j].c)*edge[j].r){
                dis[edge[j].v]=(dis[edge[j].u]-edge[j].c)*edge[j].r;
                flag=1;
            }
        if(!flag)   //优化
            break;
    }
    return i==n+1;      //相等则存在正环
}

int main(){

    //freopen("input.txt","r",stdin);

    while(~scanf("%d%d%d%lf",&n,&m,&s,&V)){
        cnt=0;
        int u,v;
        double ruv,cuv,rvu,cvu;
        while(m--){
            scanf("%d%d%lf%lf%lf%lf",&u,&v,&ruv,&cuv,&rvu,&cvu);
            addedge(u,v,ruv,cuv);
            addedge(v,u,rvu,cvu);
        }
        int ans=Bellman_ford();
        printf("%s\n",ans==1?"YES":"NO");
    }
    return 0;
}
原文地址:https://www.cnblogs.com/jackge/p/3038531.html