HDU 2199 Can you solve this equation? (二分)

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4814    Accepted Submission(s): 2247


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 
Sample Input
2
100
-4
 
Sample Output
1.6152
No solution!
 
Author
Redow
 
Recommend
lcy
 
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const double eps=1e-10;

double y;

double f(double x){
    return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6-y;
}

int main(){

    //freopen("input.txt","r",stdin);

    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%lf",&y);
        double l=0,r=100,mid;
        if(f(l)>eps || f(r)<eps){
            puts("No solution!");
            continue;
        }
        while(l+eps<=r){
            mid=(l+r)/2;
            if(f(mid)<eps)
                l=mid+eps;
            else
                r=mid-eps;
        }
        printf("%.4lf\n",l);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/jackge/p/3029665.html