POJ 3723 Conscription (最大生成树)

Conscription
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5995   Accepted: 2058

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

Source

题意:Windy要组建一支军队,需要招募N个女生和M个男生组成,需要付每个人10000RMB。现在已知这些人中有R组关系,即第x个女生和第y个男生关系为d,如果先招募了其中一个,利用他们的关系去招募另外一个,可以便宜的RMB,问Windy至少要用多少RMB才能组建成这支军队。

思路:基础的kruskal。这里要注意图不一定连通,所以是求最大生成森林。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

const int N=10010;
const int M=50010;

struct Edge{
    int u,v;
    int cap;
}edge[M<<2];

int n,m,ans,cnt;
int father[M];

void addedge(int cu,int cv,int cw){
    edge[cnt].u=cu;     edge[cnt].v=cv;     edge[cnt].cap=cw;
    cnt++;
}

void makeSet(){
    for(int i=1;i<M;i++){
        father[i]=i;
    }
}

int findSet(int x){
    if(x!=father[x]){
        father[x]=findSet(father[x]);
    }
    return father[x];
}

int cmp(Edge a,Edge b){
    return a.cap>b.cap;     ////这样排序是为了得到最小的ans
}

void Kruskal(){
    sort(edge,edge+cnt,cmp);
    for(int i=0;i<cnt;i++){
        int fx=findSet(edge[i].u);
        int fy=findSet(edge[i].v);
        if(fx!=fy){     //本题有重边,这样做同时可以去重边
            father[fy]=fx;
            ans-=edge[i].cap;
        }
    }
}

int main(){

    freopen("input.txt","r",stdin);

    int t;
    scanf("%d",&t);
    while(t--){
        cnt=0;
        makeSet();
        int q;
        scanf("%d%d%d",&n,&m,&q);
        int u,v,w;
        while(q--){
            scanf("%d%d%d",&u,&v,&w);
            addedge(u,v+n,w);
        }
        ans=(n+m)*10000;
        Kruskal();
        printf("%d\n",ans);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/jackge/p/3027131.html