POJ 1364 King ( 差分约束 )

King
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 8492   Accepted: 3203

Description

Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: ``If my child was a son and if only he was a sound king.'' After nine months her child was born, and indeed, she gave birth to a nice son. 
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence. 

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son's skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions. 

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong. 

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, ..., aSi+ni} of a sequence S = {a1, a2, ..., an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + ... + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + ... + aSi+ni < ki or aSi + aSi+1 + ... + aSi+ni > ki resp.) and declared these constraints as his decisions. 

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not. 

Input

The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king's decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0

Sample Output

lamentable kingdom
successful conspiracy

Source

题目大意:现在假设有一个这样的序列,S={a1,a2,a3,a4...ai...at}
其中ai=a*si,其实这句可以忽略不看
现在给出一个不等式,使得ai+a(i+1)+a(i+2)+...+a(i+n)<ki或者是ai+a(i+1)+a(i+2)+...+a(i+n)>ki
首先给出两个数分别代表S序列有多少个,有多少个不等式
不等式可以这样描述
给出四个参数第一个数i可以代表序列的第几项,然后给出n,这样前面两个数就可以描述为ai+a(i+1)+...a(i+n),即从i到n的连续和,再
给出一个符号和一个ki
当符号为gt代表‘>’,符号为lt代表‘<'
那么样例可以表示
1 2 gt 0
a1+a2+a3>0
2 2 lt 2
a2+a3+a4<2
最后问你所有不等式是否都满足条件,若满足输出lamentable kingdom,不满足输出successful conspiracy,这里要注意了,不要搞反了

解题思路:一个典型的差分约束,很容易推出约束不等式

首先设Si=a1+a2+a3+...+ai

那么根据样例可以得出
S3-S0>0---->S0-S3<=-1
S4-S1<2---->S4-S1<=1
因为差分约束的条件是小于等于,所以我们将ki-1可以得到一个等于号
那么通式可以表示为
a  b  gt  c
S[a-1]-s[a+b]<=-ki-1
a  b  lt  c
S[a+b]-S[a-1]<=ki-1

那么根据差分约束建图,加入这些有向边
gt:  <a+b,a-1>=-ki-1
lt:  <a-1,a+b>=ki-1
再根据bellman_ford判断是否有无负环即可
若出现负环了则这个序列不满足所有的不等式

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>

using namespace std;

const int VM=110;
const int INF=0x3f3f3f3f;

struct Edge{
    int frm,to;
    int cap;
}edge[VM<<1];

int n,m,cnt,dis[VM];

void addedge(int cu,int cv,int cw){
    edge[cnt].frm=cu;   edge[cnt].to=cv;    edge[cnt++].cap=cw;
}
/*  有点bug
int Bellman_ford(){
    int i,j;
    for(i=1;i<=n;i++)
        dis[i]=0;
    //dis[s]=V;
    for(i=1;i<=n;i++){
        int flag=0;
        for(j=0;j<cnt;j++)
            if(dis[edge[j].frm]+edge[j].cap<dis[edge[j].to]){
                dis[edge[j].to]=dis[edge[j].frm]+edge[j].cap;
                flag=1;
            }
        if(!flag)   //优化
            break;
    }
    return i==n+1;      //相等则存在正环
}
*/

int Bellman_ford(){
    int i,j;
    memset(dis,0,sizeof(dis));
    for(i=1;i<=n;i++){
        for(j=0;j<cnt;j++){
            if(dis[edge[j].frm]+edge[j].cap<dis[edge[j].to]){
                dis[edge[j].to]=dis[edge[j].frm]+edge[j].cap;
            }
        }
    }

    for(j=0;j<cnt;j++)
        if(dis[edge[j].frm]+edge[j].cap<dis[edge[j].to])
            return 0;
    return 1;
}

int main(){

    //freopen("input.txt","r",stdin);

    while(~scanf("%d",&n) && n){
        scanf("%d",&m);
        cnt=0;
        int u,v,w;
        char op[3];
        while(m--){
            scanf("%d%d%s%d",&u,&v,op,&w);
            if(op[0]=='g')
                addedge(u+v,u-1,-w-1);  //S[a-1]-s[a+b]<=-ki-1
            else
                addedge(u-1,u+v,w-1);   //S[a+b]-S[a-1]<=ki-1
        }
        if(Bellman_ford())
            printf("successful conspiracy\n");
        else
            printf("lamentable kingdom\n");
    }
    return 0;
}
原文地址:https://www.cnblogs.com/jackge/p/3017865.html