HDU 3709 Balanced Number (数位DP)

Balanced Number

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others) Total Submission(s): 965    Accepted Submission(s): 404

Problem Description
A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job to calculate the number of balanced numbers in a given range [x, y].
 
Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 1018).
 
Output
For each case, print the number of balanced numbers in the range [x, y] in a line.
 
Sample Input
2
0 9
7604 24324
 
Sample Output
10
897
 
Author
GAO, Yuan
 
Source
 
Recommend
zhengfeng
 
 
 
 
平衡数,枚举支点,然后其它的类似。加一维表示当前的力矩,注意当力矩为负时,就要返回,否则会出现下标为负,也算是个剪枝。
 
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

long long dp[20][20][2005];     //dp[i][j][k]表示考虑i位数字,支点为j,力矩和为k 
int bit[20];

long long DFS(int pos,int central,int pre,int limit){
    if(pos<=0)
        return pre==0;
    if(pre<0)       //当前力矩为负,剪枝 
        return 0;
    if(!limit && dp[pos][central][pre]!=-1)
        return dp[pos][central][pre];
    int end=limit?bit[pos]:9;
    long long ans=0;
    for(int i=0;i<=end;i++)
        ans+=DFS(pos-1,central,pre+i*(pos-central),limit&&(i==end));
    if(!limit)
        dp[pos][central][pre]=ans;
    return ans;
}

long long Solve(long long n){
    int len=0;
    while(n){
        bit[++len]=n%10;
        n/=10;
    }
    long long ans=0;
    for(int i=1;i<=len;i++)
        ans+=DFS(len,i,0,1);
    return ans-len+1;       //除掉全0的情况,00,0000满足条件,但是重复了 
}

int main(){

    //freopen("input.txt","r",stdin);

    long long a,b;
    int t;
    scanf("%d",&t);
memset(dp,-1,sizeof(dp));
while(t--){ scanf("%I64d%I64d",&a,&b); //memset(dp,-1,sizeof(dp)); printf("%I64d\n",Solve(b)-Solve(a-1)); } return 0; }
原文地址:https://www.cnblogs.com/jackge/p/2997899.html