POJ 1077 Eight (康拓展开) HDU 1043 Eight

Eight
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 19839   Accepted: 8834   Special Judge

Description

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as: 
 1  2  3  4 
  5  6  7  8 
  9 10 11 12 
 13 14 15  x 
where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle: 
 1  2  3  4    1  2  3  4    1  2  3  4    1  2  3  4 
  5  6  7  8    5  6  7  8    5  6  7  8    5  6  7  8 
  9  x 10 12    9 10  x 12    9 10 11 12    9 10 11 12 
 13 14 11 15   13 14 11 15   13 14  x 15   13 14 15  x 
            r->           d->           r-> 
The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively. 
Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and  frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course). 
In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three  arrangement. 

Input

You will receive a description of a configuration of the 8 puzzle. The description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle 
 1  2  3 
  x  4  6 
  7  5  8 
is described by this list: 
 1 2 3 x 4 6 7 5 8 

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line.

Sample Input

 2  3  4  1  5  x  7  6  8 

Sample Output

ullddrurdllurdruldr

Source

#include<iostream>
#include<queue>
#include<algorithm>
#include<string>
#include<cstring>
#include<cstdio>
//正向广度搜索
//把“x"当初0
using namespace std;

const int maxn=1000000;

int fac[]={1,1,2,6,24,120,720,5040,40320,362880};   //康拖展开判重
//         0!1!2!3! 4! 5!  6!  7!   8!    9!
int vis[maxn];

int Cantor(int s[]){        //康拖展开求该序列的hash值
    int sum=0;
    for(int i=0;i<9;i++){
        int cnt=0;
        for(int j=i+1;j<9;j++)
            if(s[i]>s[j])
                cnt++;
        sum+=(cnt*fac[9-i-1]);
    }
    return sum+1;
}

struct node{
    int s[9];
    int loc;    //“0”的位置,把“x"当0
    int status;     //康拖展开的hash值
    string path;    //路径
};

string path;
int aim=46234;  //123456780对应的康拖展开的hash值
int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};//u,d,l,r
char indexs[5]="udlr";//正向搜索
node ncur;

int BFS(){
    queue<node> q;
    while(!q.empty())
        q.pop();
    node cur,next;
    q.push(ncur);
    int x,y;
    while(!q.empty()){
        cur=q.front();
        q.pop();
        if(cur.status==aim){
            path=cur.path;
            return 1;
        }
        x=cur.loc/3;
        y=cur.loc%3;
        for(int i=0;i<4;i++){
            int tx=x+dir[i][0];
            int ty=y+dir[i][1];
            if(tx<0 || tx>=3 || ty<0 || ty>=3)
                continue;
            next=cur;
            next.loc=tx*3+ty;
            next.s[cur.loc]=next.s[next.loc];
            next.s[next.loc]=0;
            next.status=Cantor(next.s);
            if(!vis[next.status]){
                vis[next.status]=1;
                next.path=next.path+indexs[i];
                if(next.status==aim){
                    path=next.path;
                    return 1;
                }
                q.push(next);
            }
        }
    }
    return 0;
}

int main(){

    //freopen("input.txt","r",stdin);

    char ch;
    while(cin>>ch){
        if(ch=='x'){
            ncur.s[0]=0;
            ncur.loc=0;
        }else
            ncur.s[0]=ch-'0';
        for(int i=1;i<9;i++){
            cin>>ch;
            if(ch=='x'){
                ncur.s[i]=0;
                ncur.loc=i;
            }else
                ncur.s[i]=ch-'0';
        }
        ncur.status=Cantor(ncur.s);
        memset(vis,0,sizeof(vis));
        if(BFS())
            cout<<path<<endl;
        else
            printf("unsolvable\n");
    }
    return 0;
}

HDU 1043  和  POJ 1077   两题类似。。。但是输入不同。

HDU 上是同时多组输入,POJ是单组输入。

两个限时不同。

HDU 上反向搜索,把所有情况打表出来。

POJ上正向搜索。

#include<iostream>
#include<queue>
#include<string>
#include<cstdio>
#include<cstring>

using namespace std;

const int maxn=1000000;

int fac[]={1,1,2,6,24,120,720,5040,40320,362880};
int visited[maxn];
string path[maxn];

int Cantor(int s[]){
    int sum=0;
    for(int i=0;i<9;i++){
        int cnt=0;
        for(int j=i+1;j<9;j++)
            if(s[i]>s[j])
                cnt++;
        sum+=cnt*fac[9-i-1];
    }
    return sum+1;
}

struct node{
    int s[9];
    int loc;
    int status;
    string path;
}ncur;

int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};//u,d,l,r
char indexs[5]="durl";//和上面的要相反,因为是反向搜索
int aim=46234;

void BFS()
{
    memset(visited,false,sizeof(visited));
    node cur,next;
    for(int i=0;i<8;i++)cur.s[i]=i+1;
    cur.s[8]=0;
    cur.loc=8;
    cur.status=aim;
    cur.path="";
    queue<node>q;
    q.push(cur);
    path[aim]="";
    while(!q.empty())
    {
        cur=q.front();
        q.pop();
        int x=cur.loc/3;
        int y=cur.loc%3;
        for(int i=0;i<4;i++)
        {
            int tx=x+dir[i][0];
            int ty=y+dir[i][1];
            if(tx<0||tx>2||ty<0||ty>2)continue;
            next=cur;
            next.loc=tx*3+ty;
            next.s[cur.loc]=next.s[next.loc];
            next.s[next.loc]=0;
            next.status=Cantor(next.s);
            if(!visited[next.status])
            {
                visited[next.status]=true;
                next.path=indexs[i]+next.path;
                q.push(next);
                path[next.status]=next.path;
            }
        }
    }

}

int main(){

    //freopen("input.txt","r",stdin);

    char ch;
    BFS();
    while(cin>>ch){
        if(ch=='x'){
            ncur.s[0]=0;
            ncur.loc=0;
        }else
            ncur.s[0]=ch-'0';
        for(int i=1;i<9;i++){
            cin>>ch;
            if(ch=='x'){
                ncur.s[i]=0;
                ncur.loc=i;
            }else
                ncur.s[i]=ch-'0';
        }
        ncur.status=Cantor(ncur.s);
        if(visited[ncur.status])
            cout<<path[ncur.status]<<endl;
        else
            cout<<"unsolvable"<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/jackge/p/2986804.html