HDU 2844 Coins (多重背包)

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4071    Accepted Submission(s): 1629

Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 
Output
For each test case output the answer on a single line.
 
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
 
Sample Output
8
4
 
Source
 
Recommend
gaojie
 
 
#include<stdio.h>
#include<string.h>

const int maxn=100010;

int n,m;
int dp[maxn],value[120],num[120];

void ZeroOnePack(int cost,int weight){
    for(int i=m;i>=cost;i--)
        if(dp[i]<dp[i-cost]+weight)
            dp[i]=dp[i-cost]+weight;
}

void CompletePack(int cost,int weight){
    for(int i=cost;i<=m;i++)
        if(dp[i]<dp[i-cost]+weight)
            dp[i]=dp[i-cost]+weight;
}

void MultiplePack(int cost,int weight,int amount){
    if(cost*amount>=m){
        CompletePack(cost,weight);
        return ;
    }
    int k=1;
    while(k<amount){
        ZeroOnePack(k*cost,k*weight);
        amount-=k;
        k<<=1;
    }
    ZeroOnePack(amount*cost,amount*weight);
}

int main(){

    //freopen("input.txt","r",stdin);

    while(scanf("%d%d",&n,&m)){
        if(n==0 && m==0)
            break;
        for(int i=0;i<n;i++)
            scanf("%d",&value[i]);
        for(int i=0;i<n;i++)
            scanf("%d",&num[i]);
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
            MultiplePack(value[i],value[i],num[i]);
        int ans=0;
        for(int i=1;i<=m;i++)
            if(dp[i]==i)
                ans++;
        printf("%d\n",ans);
    }
    return 0;
}
原文地址:https://www.cnblogs.com/jackge/p/2978451.html