HDU 1272 小希的迷宫

小希的迷宫

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 16780    Accepted Submission(s): 5133

Problem Description
上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。 
 
Input
输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。  整个文件以两个-1结尾。
 
Output
对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出"Yes",否则输出"No"。
 
Sample Input
6 8 5 3 5 2 6 4 5 6 0 0
8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0
3 8 6 8 6 4 5 3 5 6 5 2 0 0
-1 -1
 
Sample Output
Yes
Yes
No
 
Author
Gardon
 
Source
 
Recommend
lxj
 
 
 
 
 注意陷阱: 
  0 0 Yes
  1 1 0 0  Yes
  1 2 3 4 4 5 0 0 No
 
#include<stdio.h>
#include<string.h>

const int maxn=100010;

int n,father[maxn],rank[maxn];
int edge,node,res;
int a[maxn],b[maxn],num[maxn];

int max(int a,int b){
    return a>b?a:b;
}

void makeSet(int n){
    for(int i=1;i<=n;i++){
        father[i]=i;
        rank[i]=1;
    }
}

int findSet(int x){
    if(x!=father[x]){
        father[x]=findSet(father[x]);
    }
    return father[x];
}

void Union(int a,int b){
    int x=findSet(a);
    int y=findSet(b);
    if(x==y)
        return ;
    res--;
    if(rank[x]<=rank[y]){
        father[x]=y;
        rank[y]+=rank[x];
    }else{
        father[y]=x;
        rank[x]+=rank[y];
    }
}

int main(){

    //freopen("input.txt","r",stdin);

    while(scanf("%d%d",&a[0],&b[0])){
        memset(num,0,sizeof(num));
        if(a[0]==-1 && b[0]==-1)
            break;
        if(a[0]==0 && b[0]==0){
            printf("Yes\n");
            continue;
        }
        n=1;
        edge=1;
        n=max(n,max(a[0],b[0]));
        int k=1;
        while(1){
            scanf("%d%d",&a[k],&b[k]);
            if(a[k]==0 && b[k]==0)
                break;
            n=max(n,max(a[k],b[k]));
            edge++;
            k++;
        }
        if(k==1){
            printf("Yes\n");
            continue;
        }
        makeSet(n);
        //res=n;
        for(int i=0;i<k;i++){
            num[a[i]]=1;
            num[b[i]]=1;
            //Union(a[i],b[i]);
        }
        node=0;
        for(int i=1;i<=n;i++)
            if(num[i])
                node++;
        res=node;
        for(int i=0;i<k;i++)
            Union(a[i],b[i]);
        //printf("n=%d res=%d node=%d edge=%d\n",n,res,node,edge);
        if(res==1 && node==edge+1)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}
 
 
#include<iostream>
#include<cstdio>
#include<set>

using namespace std;

struct Edge{
    int a,b;
    Edge(int _a, int _b):a(_a),b(_b){}

    bool operator < (const struct Edge &t) const {
        if(a==t.a)
            return b<t.b;
        return a<t.a;
    }

    bool operator == (const struct Edge &t) const {
        return (a==t.a) && (b==t.b);
    }
};

set<struct Edge> edge;
set<int> node;

int main(){

    //freopen("input.txt","r",stdin);

    int a,b;
    while(scanf("%d%d",&a,&b)){
        if(a==-1 && b==-1)
            break;
        if(a==0 && b==0){
            printf("Yes\n");
            continue;
        }
        edge.clear();
        node.clear();
        edge.insert(Edge(a,b));
        node.insert(a);
        node.insert(b);
        while(scanf("%d%d",&a,&b) && (a || b)){
            edge.insert(Edge(a,b));
            node.insert(a);
            node.insert(b);
        }
        if(node.size()==edge.size()+1)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}
原文地址:https://www.cnblogs.com/jackge/p/2966073.html