Max Sum Plus Plus_DP

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25572    Accepted Submission(s): 8850


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
 
Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
 
Output
Output the maximal summation described above in one line.
 
Sample Input
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 
Sample Output
6 8
Hint
Huge input, scanf and dynamic programming is recommended.

由于N比较大,用二维数组会爆掉

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int inf=0x7777777;
const int N=1000005;
int n,m;
int maxx[N],a[N],dp[N];
int main()
{
    int mm;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=m;i++)
        {
            scanf("%d",&a[i]);
            maxx[i]=0,dp[i]=0;
        }
        maxx[0]=0,dp[0]=0;
        for(int i=1;i<=n;i++)
        {
            mm=-inf;
            for(int j=i;j<=m;j++)
            {
                dp[j]=max(dp[j-1]+a[j],maxx[j-1]+a[j]);//dp在是否取a[j]的两种情况取最大值
                maxx[j-1]=mm;//maxx记录到当前位置最大值
                mm=max(mm,dp[j]);//更新最大值
            }
        }
        cout<<mm<<endl;
    }
    return 0;
}
原文地址:https://www.cnblogs.com/iwantstrong/p/5765224.html