PAT 甲级 1001 A+B Format

地址   https://pintia.cn/problem-sets/994805342720868352/problems/994805528788582400

Calculate a+b and output the sum in standard format -- that is, 
the digits must be separated into groups of three by commas (unless there are less than four digits). Input Specification: Each input file contains one test
case. Each case contains a pair of integers a and b where
106≤a,b≤106 ​​ . The numbers are separated by a space. Output Specification: For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format. Sample Input: -1000000 9 Sample Output: -999,991

题目大意是 

两数相加 使用每个三个数字打印一个','的形式将其显示出来

解答

这个主要是熟悉 字符串与数字之间的转换逆转换。

模拟题,主要注意数字和字符串的转换,并且每隔三个数字就要加上一个逗号
但是逗号任意一边只有负号或者是起点 或终点则不必添加逗号(-199 199 )

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;

int n, m;

int main()
{
    cin >> n >> m;
    int k = n + m;
    string ans;
    int flag = 0;
    if (k < 0) {flag = 1;k = abs(k);}
    else if (k == 0) {cout << 0 << endl;return 0;}

    int count = 0;
    while (k != 0) {
        int tmp = k % 10;k = k / 10;
        ans += (char)('0' + tmp);
        count++;
        if (count % 3 == 0 && k!=0) {ans += ',';}
    }
    reverse(ans.begin(),ans.end());
    if (flag) ans.insert(ans.begin(), '-');

    cout << ans << endl;
    return 0;
}

 

 如果 添加个额外的字符串空间,将两数之和的字符串逐个的复制过来,每隔复制三个字符,添加一个','  ,

思路会更清晰一些

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;

int n, m;

int main()
{
    cin >> n >> m;
    string tmp = to_string(n + m);
    string ans;
    int count=0;
    for(int i = tmp.size()-1;i>=0;i--){
        ans += tmp[i];
        count++;
        if(count%3==0 && i>0 && tmp[i-1] != '-'){
            ans+=',';
        }
    }
    reverse(ans.begin(),ans.end());
    cout << ans<<endl;
    return 0;
}
作 者: itdef
欢迎转帖 请保持文本完整并注明出处
技术博客 http://www.cnblogs.com/itdef/
B站算法视频题解
https://space.bilibili.com/18508846
qq 151435887
gitee https://gitee.com/def/
欢迎c c++ 算法爱好者 windows驱动爱好者 服务器程序员沟通交流
如果觉得不错,欢迎点赞,你的鼓励就是我的动力
阿里打赏 微信打赏
原文地址:https://www.cnblogs.com/itdef/p/14387174.html