HDU 5745 La Vie en rose

La Vie en rose

Time Limit: 14000/7000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 744    Accepted Submission(s): 386


Problem Description
Professor Zhang would like to solve the multiple pattern matching problem, but he only has only one pattern string p=p1p2...pm. So, he wants to generate as many as possible pattern strings from p using the following method:

1. select some indices i1,i2,...,ik such that 1i1<i2<...<ik<|p| and |ijij+1|>1 for all 1j<k.
2. swap pij and pij+1 for all 1jk.

Now, for a given a string s=s1s2...sn, Professor Zhang wants to find all occurrences of all the generated patterns in s.
 
Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains two integers n and m (1n105,1mmin{5000,n}) -- the length of s and p.

The second line contains the string s and the third line contains the string p. Both the strings consist of only lowercase English letters.
 
Output
For each test case, output a binary string of length n. The i-th character is "1" if and only if the substring sisi+1...si+m1 is one of the generated patterns.
 
Sample Input
3
4 1
abac
a
4 2
aaaa
aa
9 3
abcbacacb
abc
 
Sample Output
1010
1110
100100100
 
Author
zimpha
 
Source
 
 
 
解析:题意为给定一个长度为n的匹配串s和长度为m的模式串p,p可以进行变换,变换规则是任意交换两个相邻的字符,但是每个字符最多交换一次。结果输出一个n位的二进制,对于匹配串的字符位置i,如果s的子串(si,si+1,si+2,...,si+m-1)可以由p串变换得出的话,则这个位置输出“1”,否则输出“0”。
因为每次交换的字符是相邻的且每个字符最多交换一次,所以所有交换都是互不影响的,判断p是不是可以构造成目标串,只需O(m)地遍历一遍p串和对应位置的s串,遇到直接不匹配并且变换后不匹配就跳出循环并输出0,如果完全匹配则输出1。然后O(n)地枚举s的所有子串,即可在O(nm)时间得出答案(显然i>n - m就直接输出0,因为此时串s的子串长度小于串p,不可能匹配)。
 
 
 
#include <bits/stdc++.h>

char s[100005];
char p[5005];

int main()
{
    int T, n, m;
    scanf("%d", &T);
    while(T--){
        scanf("%d%d", &n, &m);
        scanf("%s%s", s, p);
        for(int i = 0; i < n; ++i){
            if(i>n-m){
                putchar('0');
                continue;
            }
            bool f = true;
            for(int j = 0; j < m; ){
                if(j<m-1 && p[j] == s[i+j+1] && p[j+1] == s[i+j]){
                    j += 2;
                    continue;
                }
                else if(p[j] != s[i+j]){
                    f = false;
                    break;
                }
                ++j;
            }
            putchar(f ? '1' : '0');
        }
        puts("");
    }
    return 0;
}

  

原文地址:https://www.cnblogs.com/inmoonlight/p/5695836.html