字符串替换

字符串替换

描述

编写一个程序实现将字符串中的所有"you"替换成"we"

 
输入
输入包含多行数据 
每行数据是一个字符串,长度不超过1000  数据以EOF结束
输出
对于输入的每一行,输出替换后的字符串
样例输入
you are what you do
样例输出
we are what we do

 
#include<iostream>
#include<string>
using namespace std;
int main()
{
string arr;
int m ;
while( getline(cin,arr) && !cin.eof())
{
    m = arr.length();
    for(int i=0;i<m;i++)
    {
    if(arr[i]=='y'&&arr[i+1]=='o'&&arr[i+2]=='u')
        {
            cout<<"we";
        i +=2;
    }
        else
        
            cout<<arr[i];
    }
    cout<<endl;
}
return 0;
}        
原文地址:https://www.cnblogs.com/imwtr/p/4069511.html