HDU 1517:A Multiplication Game

A Multiplication Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4633    Accepted Submission(s): 2631


Problem Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.
 

Input
Each line of input contains one integer number n.
 

Output
For each line of input output one line either 

Stan wins. 

or 

Ollie wins.

assuming that both of them play perfectly.
 

Sample Input
162 17 34012226
 

Sample Output
Stan wins. Ollie wins. Stan wins.
 

Source
 

Recommend
LL   |   We have carefully selected several similar problems for you:  1404 1079 1536 2147 1850 
 

你  离  开  了  ,  我  的  世  界  里  只  剩  下  雨  。  。  。

#include <iostream>
using namespace std;
int main()
{
    double n;
    while(cin>>n)
    {
        while(n > 18)n/=18;
        if(n <= 9)cout << "Stan wins." << endl;
        else cout << "Ollie wins." << endl;
    }
    return 0;
}


原文地址:https://www.cnblogs.com/im0qianqian/p/5989580.html