POJ 2629:Common permutation

Common permutation
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5510   Accepted: 1681

Description

Given two strings of lowercase letters, a and b, print the longest string x of lowercase letters such that there is a permutation of x that is a subsequence of a and there is a permutation of x that is a subsequence of b.

Input

Input consists of pairs of lines. The first line of a pair contains a and the second contains b. Each string is on a separate line and consists of at most 1,000 lowercase letters.

Output

For each subsequent pair of input lines, output a line containing x. If several x satisfy the criteria above, choose the first one in alphabetical order.

Sample Input

pretty
women
walking
down
the
street

Sample Output

e
nw
et

Source

The UofA Local 1999.10.16

你  离  开  了  ,  我  的  世  界  里  只  剩  下  雨  。  。  。

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
int main()
{
    int i, j, lena, lenb;
    string a, b, ans;
    while (getline(cin, a), getline(cin, b))
    {
        lena = a.length();
        lenb = b.length();
        ans.clear();
        for (i = 0; i < lena; i++)
            for (j = 0; j < lenb; j++)
                if (a[i] == b[j])
                {
                    ans.push_back(a[i]);
                    b[j] = '-1';
                    break;
                }
        sort(ans.begin(), ans.end());
        cout << ans << endl;
    }
}

原文地址:https://www.cnblogs.com/im0qianqian/p/5989577.html