YTU 2439: C++习题 复数类--重载运算符+

2439: C++习题 复数类--重载运算符+

时间限制: 1 Sec  内存限制: 128 MB
提交: 1022  解决: 669

题目描述

定义一个复数类Complex,重载运算符“+”,使之能用于复数的加法运算。将运算符函数重载为非成员、非友元的普通函数。编写程序,求两个复数之和。

输入

两个复数

输出

复数之和

样例输入

3 4
5 -10

样例输出

(8.00,-6.00i)

提示

前置代码及类型定义已给定如下,提交时不需要包含,会自动添加到程序前部



/* C++代码 */

#include <iostream>

#include <iomanip>

using namespace std;

class Complex

{

public:

    Complex();

    Complex(double r,double i);

    double get_real();

    double get_imag();

    void display();

private:

    double real;

    double imag;

};





主函数已给定如下,提交时不需要包含,会自动添加到程序尾部



/* C++代码 */



int main()

{

    double real,imag;

    cin>>real>>imag;

    Complex c1(real,imag);

    cin>>real>>imag;

    Complex c2(real,imag);

    Complex c3=c1+c2;

    cout<<setiosflags(ios::fixed);

    cout<<setprecision(2);

    c3.display();

    return 0;

}

迷失在幽谷中的鸟儿,独自飞翔在这偌大的天地间,却不知自己该飞往何方……

#include <iostream>
#include <iomanip>
using namespace std;
class Complex
{
public:
    Complex();
    Complex(double r,double i);
    double get_real();
    double get_imag();
    void display();
private:
    double real;
    double imag;
};
Complex :: Complex()
{
    real=0;
    imag=0;
}
double Complex::get_real()
{
    return real;
}
double Complex::get_imag()
{
    return imag;
}
Complex ::Complex(double r,double i)
{
    real=r;
    imag=i;
}
Complex operator + (Complex &c1,Complex &c2)
{
    double real;
    double imag;
    real=c1.get_real()+c2.get_real();
    imag=c1.get_imag()+c2.get_imag();
    return  Complex(real,imag);
}
void Complex::display()
{
    cout<<"("<<real<<","<<imag<<"i)"<<endl;
}
int main()
{
    double real,imag;
    cin>>real>>imag;
    Complex c1(real,imag);
    cin>>real>>imag;
    Complex c2(real,imag);
    Complex c3=c1+c2;
    cout<<setiosflags(ios::fixed);
    cout<<setprecision(2);
    c3.display();
    return 0;
}

原文地址:https://www.cnblogs.com/im0qianqian/p/5989445.html