NYOJ 113

 

字符串替换

时间限制:3000 ms | 内存限制:65535 KB
难度:2
 
描述
编写一个程序实现将字符串中的所有"you"替换成"we"
 
输入
输入包含多行数据

每行数据是一个字符串,长度不超过1000
数据以EOF结束
输出
对于输入的每一行,输出替换后的字符串
样例输入
you are what you do
样例输出
we are what we do

#include<stdio.h>
char str[1002];
int main()
{
  int i;
  while(gets(str))
  {
  	i=0;
    while(str[i]!='\0')
	if(str[i]=='y'&&str[i+1]=='o'&&str[i+2]=='u')
	{
	  printf("we");
	  i+=3;
    }
	else
	 {	
	 	printf("%c",str[i]);
	 	i++;
	 }
	putchar('\n');
  }
  return 0;
}         
原文地址:https://www.cnblogs.com/hxsyl/p/2572396.html