【P2616】 【USACO10JAN】购买饲料II Buying Feed, II

P2616 [USACO10JAN]购买饲料II Buying Feed, II


题目描述

Farmer John needs to travel to town to pick up K (1 <= K <= 100) pounds of feed. Driving D miles with K pounds of feed in his truck costs D*K cents.

The county feed lot has N (1 <= N <= 100) stores (conveniently numbered 1..N) that sell feed. Each store is located on a segment of the X axis whose length is E (1 <= E <= 350). Store i is at location X_i (0 < X_i < E) on the number line and can sell FJ as much as F_i (1 <= F_i <= 100) pounds of feed at a cost of C_i (1 <= C_i <= 1,000,000) cents per pound. Amazingly, a given point on the X axis might have more than one store.

FJ starts at location 0 on this number line and can drive only in the positive direction, ultimately arriving at location E, with at least K pounds of feed. He can stop at any of the feed stores along the way and buy any amount of feed up to the the store's limit.

What is the minimum amount FJ has to pay to buy and transport the K pounds of feed? FJ knows there is a solution.

Consider a sample where FJ needs two pounds of feed from three stores (locations: 1, 3, and 4) on a number line whose range is 0..5:

0   1   2   3   4   5 
+---|---+---|---|---+ 
1       1   1      Available pounds of feed 
1       2   2      Cents per pound 

It is best for FJ to buy one pound of feed from both the second and third stores. He must pay two cents to buy each pound of feed for a total cost of 4. When FJ travels from 3 to 4 he is moving 1 unit of length and he has 1 pound of feed so he must pay 1*1 = 1 cents.

When FJ travels from 4 to 5 he is moving one unit and he has 2 pounds of feed so he must pay 1*2 = 2 cents.

The total cost is 4+1+2 = 7 cents.

FJ开车去买K份食物,如果他的车上有X份食物。每走一里就花费X元。 FJ的城市是一条线,总共E里路,有E+1个地方,标号0~E。 FJ从0开始走,到E结束(不能往回走),要买K份食物。 城里有N个商店,每个商店的位置是X_i(一个点上可能有多个商店),有F_i份食物,每份C_i元。 问到达E并买K份食物的最小花费

输入输出格式

输入格式:

输出格式:

输入输出样例

输入样例#1:
2 5 3
3 1 2
4 1 2
1 1 1
输出样例#1:
7

说明

这么水的题为什么也要写题解。。。

因为我陷入了dp的怪圈无法自拔。对于我这种dp渣渣来说写一个这样三次循环且循环数组的dp是多么的困难。。。


于是这道题可以贪心。十分显然每一件物品对最终结果的贡献是一定的。、

这么水我居然一直再想dp,我好弱,我好弱,我好弱,我好弱,我好弱,我好弱,我好弱,我好弱,我好弱,我好弱,我好弱……

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>

const int INF = 99999999;

int k,e,n;
struct T
{
	int c,f,dir; 
	int ans;
}shop[100 + 10];

bool cmp(T a, T b)
{
	return a.ans < b.ans;
}

int cnt = 0;
int sum = 0;

int main()
{
	scanf("%d%d%d", &k, &e, &n);
	for(int i = 1;i <= n;i ++)
	{
		scanf("%d%d%d",&shop[i].dir, &shop[i].f, &shop[i].c);
		shop[i].ans = shop[i].c + e - shop[i].dir;
	}
	std::sort(shop + 1, shop + 1 + n, cmp);

	for(int i = 1;i <= n;i ++)
	{
		if(shop[i].f <= k - cnt)
		{
			sum += shop[i].ans * shop[i].f;
			cnt += shop[i].f;
		}
		else
		{
			sum += shop[i].ans * (k - cnt);
			break;
		}
	}
	printf("%d", sum);
	return 0;
}


原文地址:https://www.cnblogs.com/huibixiaoxing/p/6537734.html