You are given a string consisting of parentheses () and []. A string of this type is said to be correct:

(a)
if it is the empty string
(b)
if A and B are correct, AB is correct,
(c)
if A is correct, () and [] is correct.

Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

Input 

The file contains a positive integer n and a sequence of n strings of parentheses () and [], one string a line.

Output 

A sequence of Yes or No on the output file.

Sample Input 

3
([])
(([()])))
([()[]()])()

Sample Output 

Yes
No
Yes



解题思路:用一个栈,存下(和[,然后循环找到)和}与栈顶的符号相对应就弹出栈顶的符号,直到栈中没有元素,就输出Yes,否则No




代码如下:

#include <iostream>
#include <string>
#include <stack>
using namespace std;
int main()
{
int n;
cin>>n;
cin.get();
while(n--)
{
stack<char> s;
string str;
int flag=0;
getline(cin,str);
for(int i=0;i<str.size();i++)
{
if(str[i]=='['||str[i]=='(') s.push(str[i]);
else if(!s.empty()&&s.top()=='('&&str[i]==')') s.pop();
else if(!s.empty()&&s.top()=='['&&str[i]==']') s.pop();
else flag=1;
}
if(!flag&&!s.size()) cout<<"Yes"<<endl;
else cout<<"No"<<endl;
}
return 0;
}



原文地址:https://www.cnblogs.com/huangguodong/p/4662733.html