Printer Queue

Description

The only printer in the computer science students' union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output. 

Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority, 
and 1 being the lowest), and the printer operates as follows.
  • The first job J in queue is taken from the queue.
  • If there is some job in the queue with a higher priority than job J, thenmove J to the end of the queue without printing it.
  • Otherwise, print job J (and do not put it back in the queue).
In this way, all those importantmuffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that's life. 

Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplifymatters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.

Input

One line with a positive integer: the number of test cases (at most 100). Then for each test case:
  • One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100) and m is the position of your job (0 ≤ m ≤ n −1). The first position in the queue is number 0, the second is number 1, and so on.
  • One linewith n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.

Output

For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.

Sample Input

3
1 0
5
4 2
1 2 3 4
6 0
1 1 9 1 1 1

Sample Output

1
2
5


题目思路:通过队列模拟过程。一个队列q保存输入的数,一个优先队列v。如果q队列的第一个数是v队列中优先级最大的数,就弹出它。如果不是,就把它放在队列后面。一直这样,直到弹出需要的数


代码如下: (借鉴了,他人博客,╮(╯▽╰)╭... C++小白,求不追究责任....)

#include<iostream>
#include<queue>
using namespace std;
int main()
{
int t, n, m, x;
cin>>t;
while(t--)
{
cin>>n>>m;
queue<int>q;
priority_queue<int>v;//优先队列,一声明,就排列,按照优先级从大到小
for(int i=0; i<n; i++)
{
cin>>x;
q.push(x);//将输入的X放到q队列的队尾
v.push(x);//将输入的X放到V队列的队尾
}
while(1)
{
x=q.front();//将q队列的第一个数赋值给x,用于接下来的判断
q.pop();//弹出q队列的第一个元素,先弹出来,接下来再判断

if(m==0)
{
if(x!=v.top())//弹出来的数不是最大优先级

{
m=v.size()-1;//目标的位置变化
q.push(x);//将x(q.front)放到q队列的队尾
}
else//     是最大优先级
break;
}
else
{
m--;
if(x!=v.top()) //
q.push(x);
else
v.pop();//弹出v队列的第一个元素,也就是最大优先级的数
}
}
cout<<n-q.size()<<endl;//n减去q队列剩下的数目就是打印目标需要的时间
}
return 0;
}

/* push(x) 将x压入队列的末端

pop() 弹出队列的第一个元素(队顶元素),注意此函数并不返回任何值

front() 返回第一个元素(队顶元素)

back() 返回最后被压入的元素(队尾元素)

empty() 当队列为空时,返回true

size() 返回队列的长度
top() 返回优先队列中有最高优先级的元素*/

原文地址:https://www.cnblogs.com/huangguodong/p/4659512.html