[USACO07NOV]牛继电器Cow Relays

[USACO07NOV]牛继电器Cow Relays

题目描述

For their physical fitness program, N (2 ≤ N ≤ 1,000,000) cows have decided to run a relay race using the T (2 ≤ T ≤ 100) cow trails throughout the pasture.

Each trail connects two different intersections (1 ≤ I1i ≤ 1,000; 1 ≤ I2i ≤ 1,000), each of which is the termination for at least two trails. The cows know the lengthi of each trail (1 ≤ lengthi  ≤ 1,000), the two intersections the trail connects, and they know that no two intersections are directly connected by two different trails. The trails form a structure known mathematically as a graph.

To run the relay, the N cows position themselves at various intersections (some intersections might have more than one cow). They must position themselves properly so that they can hand off the baton cow-by-cow and end up at the proper finishing place.

Write a program to help position the cows. Find the shortest path that connects the starting intersection (S) and the ending intersection (E) and traverses exactly N cow trails.

给出一张无向连通图,求S到E经过k条边的最短路。

输入输出格式

输入格式:

  • Line 1: Four space-separated integers: N, T, S, and E

  • Lines 2..T+1: Line i+1 describes trail i with three space-separated integers: lengthi , I1i , and I2i

输出格式:

  • Line 1: A single integer that is the shortest distance from intersection S to intersection E that traverses exactly N cow trails.

输入输出样例

输入样例#1:
2 6 6 4
11 4 6
4 4 8
8 4 9
6 6 8
2 6 9
3 8 9
输出样例#1:
10

题解:

解法一:

考虑有用的点数很少,我们可以哈希一下,建立邻接矩阵,矩阵加速求出经过N条边的从S到T的最短路。

解法二:

利用倍增的思想。令f[i][j][t]表示从i到j经过2t条边的最优值,做一遍floyd再统计答案即可。

提供解法一的代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
#define inf (1e9)
using namespace std;
int n,m,s,t;
int cnt,pos[1001];
struct matrix
{
    int a[201][201];
    matrix(){for(int i=1;i<=200;i++)for(int j=1;j<=200;j++)a[i][j]=inf;}
    matrix(int b[201][201]){for(int i=1;i<=cnt;i++)for(int j=1;j<=cnt;j++)a[i][j]=b[i][j];}
    matrix operator*(matrix b)
    {
        matrix ans;
        for(int i=1;i<=cnt;i++)
            for(int j=1;j<=cnt;j++)
                for(int k=1;k<=cnt;k++)
                ans.a[i][j]=min(ans.a[i][j],a[i][k]+b.a[k][j]);
        return ans;
    }
}S,T;
int main()
{
    int i,j;
    scanf("%d%d%d%d",&n,&m,&s,&t);
    for(i=1;i<=m;i++)
    {
        int dis,from,to;
        scanf("%d%d%d",&dis,&from,&to);
        if(!pos[from])pos[from]=++cnt;
        if(!pos[to])pos[to]=++cnt;
        T.a[pos[from]][pos[to]]=T.a[pos[to]][pos[from]]=dis;
    }
    S=T;
    n--;
    while(n)
    {
        if(n&1)S=S*T;
        T=T*T;
        n>>=1;
    }
    printf("%d",S.a[pos[s]][pos[t]]);
    return 0;
}
原文地址:https://www.cnblogs.com/huangdalaofighting/p/7365855.html