HDU 1028 Ignatius and the Princess III

Ignatius and the Princess III

Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 
Sample Input
4 10 20
 
Sample Output
5 42 627
:简单的母函数问题
 
#include<iostream>
using namespace std;
#define M 125
int a[M],b[M];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int i,j,k;
        for(i=0;i<=n;i++)
         {
             a[i]=1;
             b[i]=0;
         }
         for(i=2;i<=n;i++)
         {
          for(j=0;j<=n;j++)
          {
              for(k=0;k+j<=n;k+=i)
              {
                  b[k+j]+=a[j];
              }
          }
          for(j=0;j<=n;j++)
          {
              a[j]=b[j];
              b[j]=0;
          }
         }
         cout<<a[n]<<endl;
    }
    
    return 0;
}
^^^转载请注明出处~~~
原文地址:https://www.cnblogs.com/hsqdboke/p/2454220.html