HDU 1671 Phone List

~~转载请注明出处^^

Phone List

Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 
Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 
Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 
Sample Input
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 
Sample Output
NO YES
 
#include<iostream>
using namespace std;
#include<stdlib.h>
#include<string.h>
#define M 10000+10
#define N 10+5
char a[M][N];
int cmp(const void *a,const void *b)
{
    return strcmp((char *)a,(char *)b);
}
int main()
{
    int t,i,j;
    scanf("%d",&t);
    while(t--)
    {
        int n,p,l1,l2;
        p=1;
        scanf("%d",&n);
        getchar();
        for(i=0;i<n;i++)
         gets(a[i]);
        qsort(a,n,sizeof(char)*N,cmp); //将所有字符串按字典顺序快排
        for(i=0;i<n-1;i++)
        {
            l1=strlen(a[i]);
            l2=strlen(a[i+1]);
            if(l1<=l2)
            {
            for(j=0;j<l1;j++)
            if(a[i][j]!=a[i+1][j])break;
            if(j==l1)p=0;
            }
            if(!p)break;
            
        }
        if(p)
            printf("YES\n");
        else
            printf("NO\n");
         
    }
    
    
    return 0;
}

~~转载请注明出处^^

原文地址:https://www.cnblogs.com/hsqdboke/p/2447463.html