The Dole Queue

The Dole Queue
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF


 The Dole Queue 

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

tex2html_wrap_inline34 4 tex2html_wrap_inline34 8, tex2html_wrap_inline34 9 tex2html_wrap_inline34 5, tex2html_wrap_inline34 3 tex2html_wrap_inline34 1, tex2html_wrap_inline34 2 tex2html_wrap_inline34 6, tex2html_wrap_inline50 10, tex2html_wrap_inline34 7

where tex2html_wrap_inline50 represents a space.


/////uva好坑啊,就没输出换行就WA。
#include<iostream>
#include<iomanip>
#include<string.h>
using namespace std;
int main()
{
	int n[10000],a,b,c,i,j,k;
	int s,l,b1,c1;
	while(cin>>a>>b>>c&&a)
	{
		n[0]=-9999;
		l=0;b1=0,c1=0;i=1;j=a;
		memset(n,0,sizeof(n));
		n[0]=n[0];
		s=a;
		while(s)
		{l--;c1=b1=0;
	for(;i<=a;i++)
	{
		if(n[i]==0)
			b1++;
		if(b1==b)
		{cout<<setw(3)<<i;n[i]=l;s--;break;}
		if(i==a)
			i=0;
	}
	if(s>=0)
	{
			for(;j>0;j--)
	{
				if(j==a+1)
					j--;
		if(n[j]==0||n[j]==l)
			c1++;
		if(c1==c&&n[j]!=l)
		{cout<<setw(3)<<j;n[j]=l;s--;}
	
		if(j==1)
			j=a+1;
			if(c1==c)
		{if(s!=0)
		cout<<',';
			if(s==0)
		cout<<endl;
			break;}
	}
	}

	}
	}
return 0;
}


版权声明:本文博客原创文章,博客,未经同意,不得转载。

原文地址:https://www.cnblogs.com/hrhguanli/p/4729466.html