PAT A1006 Sign In and Sign Out (25) [查找元素]

题目

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.
Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:
ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.
Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.
Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.
Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133

题目分析

给出签到记录,查找最早到和最晚走的人的姓名

解题思路

思路1

将字符串时分秒转换为整数秒,比较,最小为最早到,最大为最晚走

思路2

使用字符串进行比较,最小为最早到,最大为最晚走

知识点

一整行多个间隔字符串的输入和分割,用cin即可,cin>>id>>sit>>sot;

易错点

查找最早的记录,并不影响查找最晚的记录。比如:如果只有一条记录,那么这个人,即是最早又是最晚

Code

Code 01

#include <iostream>
#include <string>
using namespace std;
int main() {
	string id,sit,sot,ei,et="24:00:00",li,lt="00:00:00";
	int N;
	cin>>N;
	while(N-->0) {
		cin>>id>>sit>>sot;
		if(et>sit) {
			et = sit;
			ei = id;
		}
		if(lt<sot) {
			lt = sot;
			li = id;
		}
	}
	cout<<ei<<" "<<li<<endl;
	return 0;
} 

Code 02

#include <iostream>
#include <string>
using namespace std;
int main() {
	string id,sit,sot,ei,et="24:00:00",li,lt="00:00:00";
	int N;
	cin>>N;
	while(N-->0) {
		cin>>id>>sit>>sot;
		if(et>sit) {
			et = sit;
			ei = id;
		}
		if(lt<sot) {
			lt = sot;
			li = id;
		}
	}
	cout<<ei<<" "<<li<<endl;
	return 0;
}



原文地址:https://www.cnblogs.com/houzm/p/12797443.html