HDOJ-1671 Phone List

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 
Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 
Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 
Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
 
Sample Output
NO
YES
 
 
思路:经典字典树(Trie)应用,只不过这题一开始做的时候是WA的,因为自己默认号码输入顺序是按照长度递增的。。。。后来才发现。。。
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=11;

struct node{
    int m;
    int v;
    node *next[10];
    node()
    {
        for(int i=0;i<10;i++)
            next[i]=NULL;
        m=0;
    }
};

node *root;
int n;
bool flag;

void insert_tree(char* str)
{
    int len=strlen(str);
    if(root==NULL)
        root=new node;
    node *p=root,*q;
    for(int i=0;i<len;i++)
    {
        if(p->m==1)
        {
            flag=true;
            return;  //the end
        }
        int id=str[i]-'0';
        if(p->next[id]==NULL)
        {
            q=new node;
            p->next[id]=q;
            p=p->next[id];
        }
        else
        {
            p=p->next[id];
            if(i==len-1)
            {
                flag=true;
                return;  //the end;
            }
        }
        if(i==len-1)
        {
            p->m=1;
        }
    }
}

void del_tree(node* rt)
{
    for(int i=0;i<10;i++)
    {
        if(rt->next[i]!=NULL)
            del_tree(rt->next[i]);
    }
    delete rt;
}

int main()
{
    int t;
    char str[maxn];
    scanf("%d",&t);
    while(t--)
    {
        flag=false;
        root=NULL;
        scanf("%d",&n);
        while(n--)
        {
            scanf("%s",str);
            if(flag)
                continue;
            else
                insert_tree(str);
        }
        if(flag)
            cout<<"NO"<<endl;
        else
            cout<<"YES"<<endl;
        del_tree(root);
    }
    return 0;
}
 
代码:
 
原文地址:https://www.cnblogs.com/hongyang/p/5401814.html