A Mathematical Curiosity

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34939    Accepted Submission(s): 11138


Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 
Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 
Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 
Sample Input
1
 
 
10 1
20 3
30 4
0  0
 
Sample Output
Case 1: 2
Case 2: 4
Case 3: 5
 
 
本题不难,就是题目不容易完全看懂,先输入一个数N然后会分N块输入,每块再分,每次输入2个数,n,m,n=m=0时结束当前块,如果块没有结束,继续输入下一块。当a和b满足0<a<b<n且使(a^2+b^2 +m)/(ab) 的值为整数时,那么这对a和b就是一组,输出这样的组数,一行输入,跟着一样输出。
以下是我的代码:

#include<iostream>
#include <iomanip>
using namespace std;

int main()
{
int N=0;
cin>>N;
int n=0;
int m=0;
while(N--)
{
int index=1;
while(cin>>n>>m)
{
int count=0;

if((n==m)&&(n==0))
{
break;
}
else
{
int result=0;
for(int b=2;b<n;b++)
{
for(int a=1;a<b;a++)
{
result=(a*a+b*b+m)%(a*b);
if(result==0)
{
count++;
}
}
}
}
cout<<"Case "<<index<<": "<<count<<endl;
index++;
}
if(N) cout<<endl;
}
return 0;
}

 
原文地址:https://www.cnblogs.com/honeybusybee/p/5224126.html