POJ 3259 Wormholes

                                    Wormholes
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 31992   Accepted: 11614

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

 
 
用spfa判环 0.0
进队超过n次即有环~
或者用 bf 更加简洁~
 
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <string>

using namespace std;
typedef long long LL;
const int N = 1010;
const int M = 20010;
const int inf = 1e9+7;
int n , m1 , m2 ;

int eh[N] , et[M] , nxt[M] ,ew[M] , tot ;
bool inq[N] , vis[N] ;
int dis[N] , in_cnt[N];

void init(){
    tot = 0 ;
    memset( eh , -1 , sizeof eh );
    memset( vis , false , sizeof vis );
}

void addedge( int u , int v ,int w ) {
    et[tot] = v , ew[tot] = w , nxt[tot] = eh[u] , eh[u] = tot++ ;
}

bool spfa( int s ) {
    queue<int>que;
    memset( inq , false, sizeof inq );
    memset( in_cnt , 0, sizeof in_cnt );
    for( int i = 0 ; i <= n ; ++i ) dis[i] = inf ;
    que.push(s) , inq[s] = true , dis[s] = 0 , in_cnt[s]++ ;
    while( !que.empty() ) {
        int u = que.front() ; que.pop();
        inq[u] = false; vis[u] = true;
        for( int i = eh[u] ; ~i ; i = nxt[i] ) {
            int v = et[i] , w = ew[i] ;
            if( dis[u] + w < dis[v] ){
                dis[v] = dis[u] + w ;
                if( !inq[v] ) {
                    inq[v] = true;
                    in_cnt[v]++;
                    if( in_cnt[v] >= n ) return false;
                    que.push(v);
                }
            }
        }
    }
    return true;
}

void run()
{
    int u, v, w ;
    init();
    scanf("%d%d%d",&n,&m1,&m2);
    while( m1-- ) {
        scanf("%d%d%d",&u,&v,&w);
        addedge( u , v , w );
        addedge( v , u , w );
    }
    while( m2-- ) {
        scanf("%d%d%d",&u,&v,&w);
        addedge( u , v , -w );
    }
    for( int i =1 ; i <= n ; ++i ) if(!vis[i]) {
        if( !spfa(i) ) { puts("YES"); return ; }
    }
    puts("NO");
}

int main()
{
    #ifdef LOCAL
        freopen("in.txt","r",stdin);
    #endif // LOCAL
    int _ , cas = 1 ;
    cin >> _ ; while( _-- ) run();
}
View Code
 
 
 
only strive for your goal , can you make your dream come true ?
原文地址:https://www.cnblogs.com/hlmark/p/4092040.html