grids1936

1936:All in All
查看
提交
统计
提问
时间限制:
1000ms

内存限制:
65536kB
描述
You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.
输入
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.
输出
For each test case output “Yes”, if s is a subsequence of t,otherwise output “No”.
样例输入
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter
样例输出
Yes
No
Yes
No

#include<stdio.h>  
#include<string.h>  
int main(){  
    char s[100001],t[100001];  
    int i,j,len_s;  
    while(scanf("%s",s)!=EOF){  
        scanf("%s",t);  
        len_s=strlen(s);  
        for(i=0,j=0;i<strlen(t);++i){  
            if(s[j]==t[i]){  
                ++j;  
                if(j==len_s){  
                    break;  
                }  
            }  
        }  
        if(j==len_s){  
            printf("Yesn");  
        }  
        else{  
            printf("Non");  
        }   
    }    
}
原文地址:https://www.cnblogs.com/hlb430/p/2613065.html