poj2080 Calendar

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 7821 Accepted: 2919
Description
A calendar is a system for measuring time, from hours and minutes, to months and days, and finally to years and centuries. The terms of hour, day, month, year and century are all units of time measurements of a calender system.
According to the Gregorian calendar, which is the civil calendar in use today, years evenly divisible by 4 are leap years, with the exception of centurial years that are not evenly divisible by 400. Therefore, the years 1700, 1800, 1900 and 2100 are not leap years, but 1600, 2000, and 2400 are leap years.
Given the number of days that have elapsed since January 1, 2000 A.D, your mission is to find the date and the day of the week.
Input
The input consists of lines each containing a positive integer, which is the number of days that have elapsed since January 1, 2000 A.D. The last line contains an integer −1, which should not be processed.
You may assume that the resulting date won’t be after the year 9999.
Output
For each test case, output one line containing the date and the day of the week in the format of “YYYY-MM-DD DayOfWeek”, where “DayOfWeek” must be one of “Sunday”, “Monday”, “Tuesday”, “Wednesday”, “Thursday”, “Friday” and “Saturday”.
Sample Input
1730
1740
1750
1751
-1
Sample Output
2004-09-26 Sunday
2004-10-06 Wednesday
2004-10-16 Saturday
2004-10-17 Sunday
Source
Shanghai 2004 Preliminary
这道题天数很容易出错~~~

#include<stdio.h>  
int main(){  
    char w[7][10]={"Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" ,"Saturday"};  
    int m[2][13]={0,31,28,31,30,31,30,31,31,30,31,30,31,  
                  0,31,29,31,30,31,30,31,31,30,31,30,31};  
    int yd[2]={365,366};  
    long day;  
    int year,month,week;  
    int i,j,flag;  
    while(scanf("%ld",&day)&&-1!=day){  
        week=(day+6)%7;//得到星期几   
        year=2000;  
        flag=(0==year%4&&year%100!=0)||0==year%400;//flag=1为闰年   
        ++day;//题目说经过多少天,所以在这里先加1   
        for(;day>yd[flag];){//得到年份、剩余天数   
            day-=yd[flag];   
            year++;  
            flag=(0==year%4&&year%100!=0)||0==year%400;  
        }  
        for(month=1;day>m[flag][month];++month){//得到月份和对应天数   
            day-=m[flag][month];  
        }  
        printf("%d-%02d-%02d %sn",year,month,day,w[week]);//%02d很方便          
    }  
}
原文地址:https://www.cnblogs.com/hlb430/p/2613063.html