周赛C题 LightOJ 1047 (DP)

C - C
Time Limit:500MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
 

Description

The people of Mohammadpur have decided to paint each of their houses red, green, or blue. They've also decided that no two neighboring houses will be painted the same color. The neighbors of house i are houses i-1 and i+1. The first and last houses are not neighbors.

You will be given the information of houses. Each house will contain three integers "R G B" (quotes for clarity only), where R, G and Bare the costs of painting the corresponding house red, green, and blue, respectively. Return the minimal total cost required to perform the work.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case begins with a blank line and an integer n (1 ≤ n ≤ 20) denoting the number of houses. Each of the next n lines will contain 3 integers "R G B". These integers will lie in the range [1, 1000].

Output

For each case of input you have to print the case number and the minimal cost.

Sample Input

2

4

13 23 12

77 36 64

44 89 76

31 78 45

3

26 40 83

49 60 57

13 89 99

Sample Output

Case 1: 137

Case 2: 96

Hint

Use simple DP

题解:   有n家人,要把他们的房子涂上颜色,有红、绿、蓝三种颜色,每家涂不同的颜色要花不同的费用,而且相邻两户人家之间的颜色要不同,求最小的总花费费用。

     看案例可以从第一行往下模拟,然后就知道了怎么去实现,还是动态规划,求最小的值,有限制条件,每次走到点和上次走的点不在同一列。

代码:

#include<iostream>
#include<cstdio>
using namespace std;
int dp[1005][1005];
int a[1005][1005];
int main()
{
    int T,n,k=1;
    cin>>T;
    while(T--)
    {
        cin>>n;
        for(int i=1; i<=n; i++)
            for(int j=1; j<=3; j++)
                cin>>a[i][j];
        for(int i=1; i<=n; i++)
            for(int j=1; j<=3; j++)
            {
                dp[i][j%3+1]=min(dp[i-1][(j-1)%3+1],dp[i-1][(j+1)%3+1])+a[i][j%3+1];           // 相当于滚筒数组,优化
            }
        int total=min(dp[n][1],min(dp[n][2],dp[n][3]));
        cout<<"Case "<<k++<<": "<<total<<endl;
    }
}
原文地址:https://www.cnblogs.com/hfc-xx/p/4732703.html