1014 巧妙的gcd 生成元

hdu1014

 
杭电ACM 2014暑期集训队——选拔安排~
Uniform Generator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16299    Accepted Submission(s): 6381


Problem Description
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where '%' is the modulus operator. 

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1. 

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations. 

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1. 

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers. 
 

Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).
 

Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.
 

Sample Input
3 5
15 20
63923 99999
 

Sample Output
         3         5    Good Choice

        15        20    Bad Choice

     63923     99999    Good Choice
 

题目看了好久,终于看完了,发现是群论里的,离散也差多忘了。。。

说白了就是求生成元,求mod N的生成元,即生成元与N互质就OK了

#include<iostream>
int gcd(int a,int b)
{
if(!b) return a;
return gcd(b,a%b);
}
int main()
{
int s,m;
while(scanf("%d%d",&s,&m)!=EOF)
{
if(gcd(s,m)==1) printf("%10d%10d Good Choice ",s,m);
else printf("%10d%10d Bad Choice ",s,m);
}
return 0;
}

另一种暴力法

复制代码
#include<iostream>
int main()
{
int s,m,i;
while(scanf("%d%d",&s,&m)!=EOF)
{
int a[100001]={0},seed=0;
while(!a[seed])
{
a[seed]=1;
seed=(seed+s)%m;
}
for(i=0;i<m;i++)
{
if(a[i]==0)
{
printf("%10d%10d Bad Choice ",s,m);break;
}
}
if(i==m) printf("%10d%10d Good Choice ",s,m);
}
return 0;
}
复制代码
原文地址:https://www.cnblogs.com/hezixiansheng8/p/3707606.html