N^N hdu1060

Leftmost Digit
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8784    Accepted Submission(s): 3391


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 

Output
For each test case, you should output the leftmost digit of N^N.

 

Sample Input
2
3
4
 

Sample Output
2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
 
 

Author
Ignatius.L




#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<math.h>
using namespace std;
int powN(int N)
{
    int n;
    double temp,k;
    temp=log10((double)N);
    n=temp;
    k=temp-n;
    temp=N*k;
    n=temp;
    k=temp-n;
    /*开始的时候直接把N*1og(N),结果double超出了范围,
    后来我就先把temp变成小数再乘,精髓是取lg哦亲,元方你怎么看*/
    n=pow(10.0,k);
    return n;
}
int main()
{
    int T,N;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&N);
        printf("%d\n",powN(N));
    }
    return 0;
}
    
原文地址:https://www.cnblogs.com/heqinghui/p/2750482.html