多校连萌(一)C

Andy, 8, has a dream - he wants to produce hisvery own dictionary. This is not an easy task forhim, as the number of words that he knows is,well, not quite enough. Instead of thinking up allthe words himself, he has a briliant idea. Fromhis bookshelf he would pick one of his favouritestory books, from which he would copy out allthe distinct words. By arranging the words inalphabetical order, he is done! Of course, it isa really time-consuming job, and this is where acomputer program is helpful.You are asked to write a program that listsall the different words in the input text. In thisproblem, a word is defined as a consecutive sequenceof alphabets, in upper and/or lower case.Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE.For example, words like “Apple”, “apple” or “APPLE” must be considered the same.InputThe input file is a text with no more than 5000 lines. An input line has at most 200 characters. Inputis terminated by EOF.OutputYour output should give a list of different words that appears in the input text, one in a line. Thewords should all be in lower case, sorted in alphabetical order. You can be sure that he number ofdistinct words in the text does not exceed 5000.Sample InputAdventures in DisneylandTwo blondes were going to Disneyland when they came to a fork in theroad. The sign read: "Disneyland Left."So they went home.Sample Outputaadventuresblondescamedisneylandforkgoinghomeinleftreadroadsignsothetheytotwowentwerewhen

题意:读入字符串,将单词进行去重,从小到大排序,转为小写单词输出

第一次用c++的set和string类  略显生疏  以后加强练习

#include<stdio.h>
#include<iostream>
#include<string>
#include<string.h>
#include<set>
using namespace std;
set<string> s;
set<string>::iterator x;

char a[200];
char b[200];
string ans;

void change()
{
	int i,l = strlen(b);
	for(i = 0; i < l; i ++)
		if(b[i]>='A'&&b[i]<='Z')
			b[i] += 32;
}

int main()
{
	int i,j,l;
	int k ;
	s.clear() ;
	while(scanf("%s",a)!=EOF)
	{
		k = 0;
		l = strlen(a);
		for(i = 0; i < l; i ++)
		{
			if(a[i]>='a'&&a[i]<='z'||a[i]>='A'&&a[i]<='Z')
				b[k++] = a[i];
			else
			{
				b[k] = '';
				k = 0;
				if(strlen(b)>0)
				{
				   	change();
					ans = b;
				    s.insert(ans); 
				}
			}
			if(i == l-1)
			{
				b[k] = '';
				k = 0;
				if(strlen(b)>0)
				{
				   	change();
					ans = b;
				    s.insert(ans); 
				}
			}
		}
	}
	x = s.begin() ;
	for(;x!=s.end() ;x++)
		cout<<*x<<endl;
	return 0;
}


原文地址:https://www.cnblogs.com/hellocheng/p/7350101.html