[HDU 4632] Palindrome subsequence

Palindrome subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65535 K (Java/Others)
Total Submission(s): 2373    Accepted Submission(s): 950


Problem Description
In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <Sx1, Sx2, ..., Sxk> and Y = <Sy1, Sy2, ..., Syk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if Sxi = Syi. Also two subsequences with different length should be considered different.
 
Input
The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.
 
Output
For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.
 
Sample Input
4
a
aaaaa
goodafternooneveryone
welcometoooxxourproblems
 
Sample Output
Case 1: 1
Case 2: 31
Case 3: 421
Case 4: 960
 

区间DP、- -

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 1010
#define mod 10007

char s[N];
int dp[N][N]; //dp[i][j]表示区间字符串区间[i,j]的回文子串数。

int main()
{
    int t,len,i,j,iCase=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",s+1);
        len=strlen(s+1);
        memset(dp,0,sizeof(dp));
        for(i=1;i<=len;i++)
        {
            dp[i][i]=1;
        }
        for(i=len;i>=1;i--)
        {
            for(j=i+1;j<=len;j++)
            {
                if(s[i]==s[j])
                    dp[i][j]=dp[i+1][j]+dp[i][j-1]+1;
                else
                    dp[i][j]=dp[i+1][j]+dp[i][j-1]-dp[i+1][j-1];
                dp[i][j]=(dp[i][j]+mod)%mod;
            }
        }
        cout<<"Case "<<iCase++<<": "<<dp[1][len]<<endl;
    }
    return 0;
}
趁着还有梦想、将AC进行到底~~~by 452181625
原文地址:https://www.cnblogs.com/hate13/p/4065215.html