POJ 1724: Roads

Description

N cities named with numbers 1 ... N are connected with one-way roads. Each road has two parameters associated with it : the road length and the toll that needs to be paid for the road (expressed in the number of coins). 
Bob and Alice used to live in the city 1. After noticing that Alice was cheating in the card game they liked to play, Bob broke up with her and decided to move away - to the city N. He wants to get there as quickly as possible, but he is short on cash. 

We want to help Bob to find the shortest path from the city 1 to the city N that he can afford with the amount of money he has. 

Input

The first line of the input contains the integer K, 0 <= K <= 10000, maximum number of coins that Bob can spend on his way. 
The second line contains the integer N, 2 <= N <= 100, the total number of cities. 

The third line contains the integer R, 1 <= R <= 10000, the total number of roads. 

Each of the following R lines describes one road by specifying integers S, D, L and T separated by single blank characters : 
  • S is the source city, 1 <= S <= N 
  • D is the destination city, 1 <= D <= N 
  • L is the road length, 1 <= L <= 100 
  • T is the toll (expressed in the number of coins), 0 <= T <=100

Notice that different roads may have the same source and destination cities.

Output

The first and the only line of the output should contain the total length of the shortest path from the city 1 to the city N whose total toll is less than or equal K coins. 
If such path does not exist, only number -1 should be written to the output. 

Sample Input

5
6
7
1 2 2 3
2 4 3 3
3 4 2 4
1 3 4 1
4 6 2 1
3 5 2 0
5 4 3 2

Sample Output

11

The code below is based on the DFS method given in http://blog.csdn.net/l04205613/article/details/6682943.

The highlight in this code is the realization of a linklist using sequential array structure, which could be much faster than realizations using pointers. I have tried adjacent matrix to represent the data, but always got a TLE or RE. I believe this tricky method is familiar to those who take part in ACM contest. 

Several optimizations could be added to make this method even faster. First, if we arrive at a previously visited city (via another path), and find that both our current cost and path length exceed the values we spent via a previous path, we can simply do a backtrack since we have already found a better path than current one. Second, when performing addEdge operation, if a road from city A to city B is longer and more costly than another road from A to B, we can simply ignore it.

Here's the code.

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int N = 1010;
const int INF = 1e6;

struct Edge
{
    int s, e, len, cost;
    int next;
} edge[10 * N];

int n,m,e_num,head[N],vis[N];
int ans;

void AddEdge(int a, int b, int c, int d)
{

    edge[e_num].s = a; edge[e_num].e = b; edge[e_num].len = c; edge[e_num].cost = d;
    //用数组来实现链表,将具有相同起点的路串起来
    edge[e_num].next = head[a]; 
    head[a] = e_num; 
    e_num++;
}

void dfs(int id, int dist, int money) //当前点的下标,当前离开起点的距离,还剩下的钱
{
    if(dist > ans)
        return;//如果距离变大的话,回溯
    if(id == n && money >= 0 && dist < ans) 
        ans = dist;//到达终点赋值
    for(int i = head[id]; i ! = -1; i = edge[i].next)
    {
        int u = edge[i].e;
        if(!vis[u] && money >= edge[i].cost){
            vis[u] = 1;
            dfs(u, dist+edge[i].len, money - edge[i].cost);
            vis[u] = 0;
        }
    }
}

int main()
{
    int i, a, b, c, d, k;
    scanf("%d%d%d", &k, &n, &m);
    e_num = 0;
    memset(head, -1, sizeof(head));
    for(i = 0; i < m; i++){
        scanf("%d%d%d%d", &a, &b, &c, &d);
        AddEdge(a, b, c, d);
    }
    ans = INF;
    memset(vis, 0, sizeof(vis));
    dfs(1, 0, k);
    printf(ans < INF ? "%d
" : "-1
", ans);
    return 0;
}
原文地址:https://www.cnblogs.com/happypku/p/3144575.html