Go Home

问题 F: Go Home

时间限制: 1 Sec  内存限制: 128 MB
提交: 44  解决: 28
[提交][状态][讨论版][命题人:admin]

题目描述

There is a kangaroo at coordinate 0 on an infinite number line that runs from left to right, at time 0. During the period between time i−1 and time i, the kangaroo can either stay at his position, or perform a jump of length exactly i to the left or to the right. That is, if his coordinate at time i−1 is x, he can be at coordinate x−i, x or x+i at time i. The kangaroo's nest is at coordinate X, and he wants to travel to coordinate X as fast as possible. Find the earliest possible time to reach coordinate X.

Constraints
X is an integer.
1≤X≤109
 

输入

The input is given from Standard Input in the following format:
X

输出

Print the earliest possible time for the kangaroo to reach coordinate X.

样例输入

6

样例输出

3

提示

The kangaroo can reach his nest at time 3 by jumping to the right three times, which is the earliest possible time.

//贪心

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

int main()
{
    int x;
    cin>>x;
    int now = 0;
    for(int i=1;i<=x;i++)
    {
        now+=i;
        if(now>=x)
        {
            cout<<i;
            break;
        }


    }
}
原文地址:https://www.cnblogs.com/hao-tian/p/9152456.html