Train Problem II(卡特兰数+大数乘除)

Train Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7539    Accepted Submission(s): 4062

Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.
 
Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.
 
Output
For each test case, you should output how many ways that all the trains can get out of the railway.
 
Sample Input
1 2 3 10
 
Sample Output
1 2 5 16796
Hint
The result will be very large, so you may not process it by 32-bit integers.
 
题解:卡特兰数:h( n ) = ( ( 4*n-2 )/( n+1 )*h( n-1 ) );也可以用java,h(n)= h(0)*h(n-1) + h(1)*h(n-2) + + h(n-1)h(0) (其中n>=2);
这里用的大数;
代码:
#include<cstdio>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<stack>
using namespace std;
const int INF=0x3f3f3f3f;
#define mem(x,y) memset(x,y,sizeof(x))
#define SI(x) scanf("%d",&x)
#define PI(x) printf("%d",x)
int N;
//h( n ) = ( ( 4*n-2 )/( n+1 )*h( n-1 ) );
int ans[110][110];
void db(){
    ans[0][0]=1;
    ans[0][1]=1;
    ans[1][0]=1;
    ans[1][1]=1;
    int len=1,yu=0;
    for(int i=2;i<=100;i++){
        for(int j=1;j<=len;j++){
            int t=ans[i-1][j]*(4*i-2)+yu;
            yu=t/10;
            ans[i][j]=t%10;
        }
        while(yu){
            ans[i][++len]=yu%10;
            yu/=10;
        }
        for(int j=len;j>=1;j--){
            int t=ans[i][j]+yu*10;
            ans[i][j]=t/(i+1);
            yu=t%(i+1);
        }
        while(!ans[i][len])len--;
        ans[i][0]=len;
    }
}
int main(){
    mem(ans,0);
    db();
    while(~SI(N)){
        for(int i=ans[N][0];i>=1;i--)printf("%d",ans[N][i]);
        puts("");
    }
    return 0;
}
原文地址:https://www.cnblogs.com/handsomecui/p/5228734.html