UVA

UVA - 1103Ancient Messages

In order to understand early civilizations, archaeologists often study texts written in ancient languages.
One such language, used in Egypt more than 3000 years ago, is based on characters called hieroglyphs.
Figure C.1 shows six hieroglyphs and their names. In this problem, you will write a program to recognize
these six characters.
Figure C.1: Six hieroglyphs
Input
The input consists of several test cases, each of which describes an image containing one or more
hieroglyphs chosen from among those shown in Figure C.1. The image is given in the form of a series
of horizontal scan lines consisting of black pixels (represented by 1) and white pixels (represented by
0). In the input data, each scan line is encoded in hexadecimal notation. For example, the sequence of
eight pixels 10011100 (one black pixel, followed by two white pixels, and so on) would be represented in
hexadecimal notation as 9c. Only digits and lowercase letters a through f are used in the hexadecimal
encoding. The first line of each test case contains two integers, H and W. H (0 < H ≤ 200) is the
number of scan lines in the image. W (0 < W ≤ 50) is the number of hexadecimal characters in each
line. The next H lines contain the hexadecimal characters of the image, working from top to bottom.
Input images conform to the following rules:
• The image contains only hieroglyphs shown in Figure C.1.
• Each image contains at least one valid hieroglyph.
• Each black pixel in the image is part of a valid hieroglyph.
• Each hieroglyph consists of a connected set of black pixels and each black pixel has at least one
other black pixel on its top, bottom, left, or right side.
• The hieroglyphs do not touch and no hieroglyph is inside another hieroglyph.
• Two black pixels that touch diagonally will always have a common touching black pixel.
• The hieroglyphs may be distorted but each has a shape that is topologically equivalent to one of
the symbols in Figure C.1. (Two figures are topologically equivalent if each can be transformed
into the other by stretching without tearing.)
The last test case is followed by a line containing two zeros.
Output
For each test case, display its case number followed by a string containing one character for each
hieroglyph recognized in the image, using the following code:
Ankh: A
Wedjat: J
Djed: D
Scarab: S
Was: W
Akhet: K
In each output string, print the codes in alphabetic order. Follow the format of the sample output.
The sample input contains descriptions of test cases shown in Figures C.2 and C.3. Due to space
constraints not all of the sample input can be shown on this page.
Figure C.2: AKW Figure C.3: AAAAA
Sample Input
100 25
0000000000000000000000000
0000000000000000000000000
...(50 lines omitted)...
00001fe0000000000007c0000
00003fe0000000000007c0000
...(44 lines omitted)...
0000000000000000000000000
0000000000000000000000000
150 38
00000000000000000000000000000000000000
00000000000000000000000000000000000000
...(75 lines omitted)...
0000000003fffffffffffffffff00000000000
0000000003fffffffffffffffff00000000000
...(69 lines omitted)...
00000000000000000000000000000000000000
000000000000000000000000000000000000

00000000000000000000000000000000000000
0 0
Sample Output
Case 1: AKW
Case 2: AAAAA

题解:傻不拉唧的自己,倒腾了测试数据还以为自己的代码错了呐,倒腾数据弄了半天,最终发现原来是没删了freopen("data.in","r",stdin);

我哩个无语啊。。。。

题意是让升序输出象形文字代表的字母,可以根据里面圆的个数判断;

测试数据:

http://demo.netfoucs.com/u013451221/article/details/38179321

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
#define mem(x,y) memset(x,y,sizeof(x))
#define SI(x) scanf("%d",&x)
#define PI(x) printf("%d",x)
#define P_ printf(" ")
const int INF=0x3f3f3f3f;
typedef long long LL;
const int MAXN=1010;
int w,h,cnt;
int mp[MAXN][MAXN];
char ans[MAXN];
char s[MAXN];
char an[6]={'W','A','K','J','S','D'};
char ch[]={'0','1','2','3','4','5','6','7','8','9','a','b','c','d','e','f'};
int disx[8]={0,0,1,-1,1,1,-1,-1};
int disy[8]={1,-1,0,0,-1,1,-1,1};
int p[16][4]={
	 {0,0,0,0},{0,0,0,1},{0,0,1,0},{0,0,1,1},
  {0,1,0,0},{0,1,0,1},{0,1,1,0},{0,1,1,1},
  {1,0,0,0},{1,0,0,1},{1,0,1,0},{1,0,1,1},
  {1,1,0,0},{1,1,0,1},{1,1,1,0},{1,1,1,1}
};
void dfs(int x,int y){
	if(x<0||y<0||x>w+1||y>4*h+1)return;
	if(mp[x][y])return;
	mp[x][y]=-1;
	for(int i=0;i<8;i++)
		dfs(x+disx[i],y+disy[i]);
}
void dfs2(int x,int y){
	if(x<0||y<0||x>w||y>4*h)return;
	if(mp[x][y]==-1)return;
	if(mp[x][y]==0){
		dfs(x,y);cnt++;
		return;
	}
	mp[x][y]=-1;
	for(int i=0;i<8;i++)
		dfs2(x+disx[i],y+disy[i]);
}
int cmp(char a,char b){
	return a<b;
}
int main(){
	int k,l,kase=0;
//	 freopen("data.in","r",stdin);
//	freopen("data.out","w",stdout);
	while(scanf("%d%d",&w,&h),w|h){
		mem(mp,0);
		mem(ans,0);
		for(int i=1;i<=w;i++){
			scanf("%s",s);
			l=1;
			int len=strlen(s);
			for(int j=0;j<h;j++){
				for(k=0;k<16;k++)
					if(s[j]==ch[k]){
					for(int x=0;x<4;x++)
					mp[i][l++]=p[k][x];
					break;
					}
			}
		}
		dfs(0,0);
		k=0;
		for(int i=0;i<=w;i++)
			for(int j=0;j<4*h;j++){
				if(mp[i][j]==1){
					cnt=0;
					dfs2(i,j);
					ans[k++]=an[cnt];
				}
			}
			sort(ans,ans+k,cmp);
			printf("Case %d: ",++kase);
		for(int i=0;i<k;i++)printf("%c",ans[i]);
		puts("");
	}
	return 0;
}

  

原文地址:https://www.cnblogs.com/handsomecui/p/5098250.html