数据结构实验之链表一:顺序建立链表

题目描述

输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。

输入

第一行输入整数的个数N;
第二行依次输入每个整数。

输出

输出这组整数。

示例输入

8
12 56 4 6 55 15 33 62

示例输出

12 56 4 6 55 15 33 62

提示

不得使用数组!
#include <stdio.h>
#include <malloc.h>
struct node
{
	int data;
	struct node *next;
};
struct node *creat(int n)
{
	struct node *head,*tail,*p;
	int i;
	head = (struct node *)malloc(sizeof(struct node));
	head->next = NULL;
	tail = head;
	for(i  = 1;i<=n;i++)
	{
		p = (struct node *)malloc(sizeof(struct node));
		scanf("%d",&p->data);
		p->next = NULL;
		tail->next = p;
		tail = p;
	}
	return (head);
};
int main()
{
	int n;
	struct node *head;
	scanf("%d",&n);
	head = creat(n);
	struct node *r;
	r = head;
	while(r->next!=NULL)
	{
		r->next->next==NULL?printf("%d",r->next->data):printf("%d ",r->next->data);
		r = r->next;
	}
	printf("\n");
	return 0;
}
原文地址:https://www.cnblogs.com/haidong/p/2348163.html