1149 Dangerous Goods Packaging

When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化剂) must not be packed with flammable liquid (易燃液体), or it can cause explosion.

Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: N (≤), the number of pairs of incompatible goods, and M (≤), the number of lists of goods to be shipped.

Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:

K G[1] G[2] ... G[K]
 

where K (≤) is the number of goods and G[i]'s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.

Output Specification:

For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.

Sample Input:

6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333
 

Sample Output:

No
Yes
Yes

题意:

  给出一组不能放在一起的商品的清单,然后再给出要装箱的商品的清单,判断这些要装箱的商品能不能放在一起。

思路:

  用map和set来进行模拟就好了。

Code:

#include<iostream>
#include<map>
#include<set>
#include<vector>

using namespace std;

int main() {
    int n, m, k, t;
    cin >> n >> m;

    int g1, g2;
    set<int> seen;
    map<int, set<int> >  mp;
    set<int> shapped;
    for (int i = 0; i < n; ++i) {
        cin >> g1 >> g2;
        seen.insert(g1);
        seen.insert(g2);
        mp[g1].insert(g2);
        mp[g2].insert(g1);
    }
    for (int i = 0; i < m; ++i) {
        cin >> k;
        shapped.clear();
        bool flag = false;
        for (int j = 0; j < k; ++j) {
            cin >> t;
            if (seen.find(t) != seen.end())
                shapped.insert(t);
        }
        for (auto good : shapped) {
            for (auto it : mp[good]) {
                if (shapped.find(it) != shapped.end()) {
                    cout << "No" << endl;
                    flag = true;
                    break;
                }
            }
            if (flag) break;
        }
        if (!flag) cout << "Yes" << endl;
    }

    return 0;
}

  这道题我之前参加PAT乙级考试的时候碰到过,记得当时自己还在上大二,自己听了老师说有PAT这种考试,然后自己就一个人只身一人跑到ZZ去参加考试,当时以为是第一次去ZZ,对那里的公交也不是太熟悉,第一次竟然还坐反方向。其实当时如果坐地铁的话应该会更好。

  记得当时这道题我没有做出来,现在再做这道题,感觉轻松了不少。

永远渴望,大智若愚(stay hungry, stay foolish)
原文地址:https://www.cnblogs.com/h-hkai/p/12676619.html