1153 Decode Registration Card of PAT

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤) and M (≤), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999
 

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

题意:

思路:

Code:

#include<iostream>
#include<algorithm>
#include<string>
#include<vector>
#include<unordered_map>
#include<cstdio>

using namespace std;

struct Info {
    char level;
    string site;
    string date;
    string testee;
    int sorce;
    string cardNumber;
};

bool cmp1(Info a, Info b) {
    if (a.sorce == b.sorce)
        return a.cardNumber < b.cardNumber;
    return a.sorce > b.sorce;
}

bool cmp2(pair<string, int> a, pair<string, int> b) {
    if (a.second == b.second) 
        return a.first < b.first;
    return a.second > b.second;
}

int main() {
    int n, m;
    scanf("%d%d", &n, &m);
    string info;
    int sorce;
    Info submit;
    vector<Info> v(n);
    for (int i = 0; i < n; ++i) {
        cin >> info >> sorce;
        v[i].level = info[0];
        v[i].site = info.substr(1, 3);
        v[i].date = info.substr(4, 6);
        v[i].testee = info.substr(10, 3);
        v[i].sorce = sorce;
        v[i].cardNumber = info;
    }

    getchar();
    string Case;
    for (int i = 1; i <= m; ++i) {
        getline(cin, Case);
        int Type = Case[0] - '0';
        string Term = Case.substr(2);
        switch (Type) {
        case 1: {
            cout << "Case " << i << ": " << Case << endl;
            char l = Term[0];
            sort(v.begin(), v.end(), cmp1);
            if (v.size() == 0) {
                cout << "NA" << endl;
            } else {
                for (int i = 0; i < v.size(); ++i) {
                    if (v[i].level == l) {
                        cout << v[i].cardNumber << " " << v[i].sorce << endl;
                    }
                }
            }

            break;
        }
        case 2: {
            int Nt = 0, Ns = 0;
            cout << "Case " << i << ": " << Case << endl;
            for (int i = 0; i < v.size(); ++i) {
                if (v[i].site == Term) {
                    Nt++;
                    Ns += v[i].sorce;
                }
            }
            if (Nt == 0) {
                cout << "NA" << endl;
            } else {
                cout << Nt << " " << Ns << endl;
            }
            
            break;
        }
        case 3: {
            cout << "Case " << i << ": " << Case << endl;
            unordered_map<string, int> mp;
            for (int i = 0; i < v.size(); ++i) {
                if (v[i].date == Term) {
                    mp[v[i].site]++;
                }
            }
            vector<pair<string, int> > temp;
            for (auto it = mp.begin(); it != mp.end(); ++it) {
                temp.push_back({it->first, it->second});
            }
            sort(temp.begin(), temp.end(), cmp2);
            if (temp.size() == 0) { 
                cout << "NA" << endl;
            } else {
                for (int i = 0; i < temp.size(); ++i) {
                    cout << temp[i].first << " " << temp[i].second << endl;
                }
            }

            break;
        }
        
        default:
            break;
        }
    }


    return 0;
}

  

本来以为很简单,但是提交的时候发现就通过了一组数据,怎么说呢?感觉写的代码没毛病,为什么就通过一组数据呢?

永远渴望,大智若愚(stay hungry, stay foolish)
原文地址:https://www.cnblogs.com/h-hkai/p/12654084.html